Docker Community Forums

Share and learn in the Docker community.

Adding vCPU caused bad performance


(Lindeamon) #1

Hi All,

i have a blade with 2sockets, 8 core per socket and hyper threading enabled.
i have esxi v5.1 enterprise license with no vcenter
i run 5 VM’s on local storage. i gave each VM 1 vCpu and 4GB of RAM.
each VM has 50GB of thick provisioned disk.
each vm is configured as hardware version 7 and RHEL 6 x64
each VM was duplicate from a template which was initially installed with 1 vCpu.
each VM is running RHEL 7.2 x64 with minimal install and swap size of 1GB.
each VM is running docker CE v1.12.3
i run 14 docker containers on each VM when 3 of them are running node.js app and the rest are running java.
i have noticed that there was no memory or cpu limit on the running containers.

well,
this is the setup i got from a former employee and i wanted to add 1 vcpu to one of the VM’s.
shutting down the VM, adding 1 vcpu and powering it on and the VM performs as expected.
as i started running the containers the system became unresponsive after the 8th container {all of them run java inside} and i have noticed that the disk usage went up to 100% as the containers consumed all the physical memory and the swap memory.
i have changed the number of vcpu’s back to 1 and everything started working again with all the containers up and running.
i have tried figuring out why a change to the amount of cpu will effect the behavior of the java/container but came up with nothing.

appreciate the help.
Lindeamon