Docker Community Forums

Share and learn in the Docker community.

Amazon Web Services: Add Credential documentation not worked

amazonwebservices

(Jivangoyal) #1

Expected behavior

To configure AWS, in cloud providers, used help document :

Using help document, I configured the policy and role in aws, as per documentation. And then checked to enter role arn as expected in documentation under docker cloud providers -> amazon web services. But there is no option as described in documentation as it seems already changed.

Actual behavior

In actual, it requires two values:
Access Key Id
Secret access key

I am not sure what correct values to be filled in these fields

Additional Information

I tried Role ARN, with secret access key as pwd of docker as as well as of aws console. Both gives error:

Invalid AWS role or insufficient permissions

Please guide me, what more changes I need to apply in addition to steps described in documentation.


(Jivangoyal) #2

I faced this issue as I was in classic view, where two options are asked. But, when re-browsed docker cloud with new ui, and browsed CLOUD SETTINGS, under last option SETTINGS. Then it shown same ui as shown in documentation. And clicking on AWS option icon to enter ARN Role value (ensuring it starts with arn:, that I missed to include, initially) it worked fine.

So, if anyone again face similar issue please ensure ARN role have all parts copied correctly including it should start with “arn:aws:iam::”

As my issue is resolved so marking this issue fixed.