Docker Community Forums

Share and learn in the Docker community.

Are you trying to connect to a TLS-enabled daemon without TLS?


(Ярослав) #1

Runs the command on windows server 2012 r2

docker run hello-world

and I get

Post http://127.0.0.1:2375/v1.19/containers/create: dial tcp 127.0.0.1:2375: Con
nectEx tcp: No connection could be made because the target machine actively refu
sed it… Are you trying to connect to a TLS-enabled daemon without TLS?


(Joe) #2

Hi,

I have seen this problem.

It is quite possible that the docker service is not running. To confirm that, do this:

ps aux | grep docker

If the result does not show a line for docker, i.e. it just shows a line for grep and nothing else, it means that the docker service was not started.

So, to start the docker service, say:

sudo service docker start

Now do a:

ps aux | grep docker

and confirm that the docker service is running.

Now try:

docker version

and you should not see the same problem.

Let me know if this works.

Cheers,
Joe P


(Ярослав) #3

When executes the command
sc start docker
getting
[SC] StartService: OpenService: error: 1060:
The specified service is not installed

And then, all the same, perform
sh-3.1 $ docker version

Client version: 1.7.0
Client API version: 1.19
Go version (client): go1.4.2
Git commit (client): 0baf609
OS / Arch (client): windows / amd64
Get http://127.0.0.1:2375/v1.19/version: dial tcp 127.0.0.1:2375: ConnectEx tcp:
No connection could be made because the target machine actively refused it … Ar
e you trying to connect to a TLS-enabled daemon without TLS?


Cannot run Hello World | No connection can be made because the target
(Joe) #4

Hi Yaruslav,

I know what the problem is.

You have installed the docker client and not the docker server.

Here is what you should see (or something like this) when you run “docker version”:

Client version: 1.6.2
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 7c8fca2
OS/Arch (client): linux/amd64
Server version: 1.6.2
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 7c8fca2
OS/Arch (server): linux/amd64

In your case it is showing info about the docker client but when it comes to the docker server it has issues. So check that.

More importantly, you say you run on Windows Server 2012. You have installed “boot2docker”, right?

I would say, focus on the server part of the docker. I think there is a problem there in your environment.

Let me know what you find.

Cheers,
Joe P


(Sakthishan91) #5

Start the DOCKER service on machine


(Ярослав) #6

Well, what to say, installed on windows 8.1 everything works immediately


(Joe) #7

For folks that stumble upon this page after googling “Are you trying to connect to a TLS-enabled daemon without TLS?”, the info below might solve your problem:

If you are on Windows and running boot2docker to play with the Docker containers, you will see this problem, if you did not run the “start” script that comes with the boot2docker and simply started the Git Bash Shell.

In that case, set the following 3 env vars and you should be good to go:

export DOCKER_HOST=tcp://<ip_addr>:2376
export DOCKER_CERT_PATH='C:<boot2docker_install_dir>\certs\boot2docker-vm’
export DOCKER_TLS_VERIFY=1

For exact values, do a “boot2docker start” at the shell prompt and it will show you the 3 statements from above.

Cheers.

-Joe


(Sven Dowideit) #8

The command you should be running to initialise the environment variables is

eval "$(boot2docker shellinit)"


(Ярослав) #9

Администратор@WIN-TFLGSTDLO7L ~
$ docker run hello-world
Post http://127.0.0.1:2375/v1.19/containers/create: dial tcp 127.0.0.1:2375: Con
nectEx tcp: No connection could be made because the target machine actively refu
sed it… Are you trying to connect to a TLS-enabled daemon without TLS?

Администратор@WIN-TFLGSTDLO7L ~
$ boot2docker start
error in run: Failed to start machine “boot2docker-vm”: exit status 1

Администратор@WIN-TFLGSTDLO7L ~
$ eval "$(boot2docker shellinit)"
error in run: VM “boot2docker-vm” is not running. (Did you run boot2docker up?
)


(Sinjihn Smith) #10

I’m having exactly the same issue as this guy. I’m also using Windows Server 2012. I saw that this issue has something to do with virtualbox using vt-x and that not being enabled in the BIOS (related to: https://github.com/boot2docker/windows-installer/issues/63#issuecomment-128411499)

Everything that myr4ik07 has done I have also tried and had the same results. The docker service isn’t running because it can’t start the VM, and the VM can’t start because it needs hardware virtualization enabled. The workaround needs to be found at the level of virtual box, unfortunately.


(Avinash Kumar Singh) #11

faced the same issue when I was creating docker image from Jenkins simply add the user to docker group and then restart docker services and in my case I have to restart Jenkins services

This was the error which I got

http:///var/run/docker.sock/v1.19/build?cgroupparent=&cpuperiod=0&cpuquota=0&cpusetcpus=&cpusetmems=&cpushares=0&dockerfile=Dockerfile&memory=0&memswap=0&rm=1&t=59aec062a8dd8b579ee1b61b299e1d9d340a1340: dial unix /var/run/docker.sock: permission denied. Are you trying to connect to a TLS-enabled daemon without TLS?
FATAL: Failed to build docker image from project Dockerfile
java.lang.RuntimeException: Failed to build docker image from project Dockerfile


Solution: 

[root@Jenkins ssh]# groupadd docker
[root@Jenkins ssh]# gpasswd -a jenkins docker
Adding user jenkins to group docker
[root@Jenkins ssh]# /etc/init.d/docker restart
Stopping docker:                                           [  OK  ]
Starting docker:                                           [  OK  ]
[root@Jenkins ssh]# /etc/init.d/jenkins restart
Shutting down Jenkins                                      [  OK  ]
Starting Jenkins                                           [  OK  ]
[root@Jenkins ssh]#

(Klahnen) #12

I think the issue is about your shell, bash or cmd is not loading environment variables properly. Where can we find those vars and add it?


(Bboysathish) #13

I am still getting this error, i tried all possible ways explained here.
But i am using docker toolbox for using docker.

1.This is what i have done installed docker on to clean machine.
2. Started docker quick start shell
3. Then it showed this log

docker is configured to use the default machine with IP 192.168.99.100

Next i typed docker version

This is what i got,

$ docker version
Client version: 1.7.0
Client API version: 1.19
Go version (client): go1.4.2
Git commit (client): 0baf609
OS/Arch (client): windows/amd64
Get http://127.0.0.1:2375/v1.19/version: dial tcp 127.0.0.1:2375: ConnectEx tcp: No connection could be made because the target machine actively refused it.. Are you trying to connect to a TLS-enabled daemon without TLS?

More Info:

Virtual Box and GIT Installed with Docker ToolBox and its version is,

VirtualBox Graphical User Interface
Version 5.0.6 r103037
Copyright © 2015 Oracle Corporation and/or its affiliates. All rights reserved.

Is there anything i need to do to make this work?


(Caparzo) #14

bboysathish: try to run Docker quickstart terminal as administrator. This solved my problem. Also check your firewall settings whether the traffic which Docker generates is not blocked.


(Sbanal) #15

This issue also happened to my machine. Using Docker Toolbox 1.9.0 and Windows 8.1 Pro.
To fix the issue I did the following:

  1. Uninstall both Docker Toolbox and Virtual Box
  2. Remove folders .docker and .VirtualBox under folder c:\Users\{windows account username}\
  3. Remove all “VirtualBox Host-Only Ethernet Adapter” from Device Manager window
  4. Restart machine
  5. Re-install Docker Toolbox
  6. Click Docker Quick Start Terminal

Spotify docker-maven-plugin can't connect to localhost:2375