Docker Community Forums

Share and learn in the Docker community.

AWS account link always fails

Expected behavior

AWS account links

Actual behavior

Always fails with insufficient with permissions

Additional Information

Tried the policy and role setup from docs (in new docker GUI) and no luck.
Tried with root creds in old docker GUI and no luck.
Tried with aws user with admin creds in old GUI and no luck.

1 Like

The troubleshooting image test, when configured with us-west-2 and t2.micro image passes.

No matter how I config the IAM role trust relationship or the IAM policy I seem to get the same error when I try to add the AWS cloud provider.

I had this issue, but the ARN worked after a while… The only thing I did was email AWS verification services constantly about issues I had in my account, until they fully activated it for EC2 (it was restricted and cased issues). I launched an ECS task, that worked fine in the region I wanted, then authentication worked on docker cloud.

TL;DR - this is an AWS issue, please seek assistance from them.