Docker Community Forums

Share and learn in the Docker community.

Beware of the 1.4 upgrade


(Eric5102) #1

The DTR ui offers the upgrade as a minor upgrade but it is actually not backward compatible. It warns you AFTER the upgrade that it requires the engine 1.9. That version is not available in some cloud environments yet so upgrading becomes a death trap

Eric


(Jonchu) #2

Hi Eric,

I’m the PM that owns DTR, and I apologize for the inconvenience.

The commercially supported engine upgrades for DTR are done through your OS’s package manager from public Docker repositories, so this upgrade should be available in any cloud environment that has Internet access. Have you checked your security groups to make sure you aren’t blocking the engine upgrade?

Additionally, are you sure your package manager is pointing to the right Docker repositories? If you use public repositories that come by default on your OS, this may not upgrade your engine correctly. Please refer to the upgrade instructions here: https://docs.docker.com/docker-trusted-registry/install/upgrade

DTR 1.4 does work on cs engine 1.6 although this is not recommended. Hopefully, this resolves your issue, but if not, can you please file a ticket with support? I’ll track the ticket and have someone dig into this on my end. We take upgrade failure very seriously so I appreciate the notification here.

Jon


(Eric5102) #3

Hi Jon,

I did open a ticket (8463). I restored a backup as this was the only solution. Some AWS services like Beanstalk allow deploying through docker but we have little control on the Docker version. Currently they support up to 1.7.1 and it is impossible to upgrade version before their service itself does.

DTR 1.4 does work on cs engine 1.6 although this is not recommended.

It didn’t work here. Unfortunately I did not keep the error message but it did fail and the DTR message after the upgrade did state DTR 1.4 now required the 1.9 engine and this was not contradicted by support who just told us to upgrade the engine. Since this is impossible we reverted to 1.3.3

Eric


(Jonchu) #4

Ok cool. Thanks Eric. It looks like Beanstalk is on 1.7.1 rather than 1.6, so that would make sense to me. I’ll follow up with support and have them see if they can figure out a solution.


(Shawn Bower) #5

The 1.4 upgrade has been a nightmare for us as well, there are indeed breaking changes. Your repositories and organizations will not appear in the UI until you manually create them all. We had repositories under the root of our private repo that no longer work and will have to be manually upgraded. The process to upgrade from CS 1.6 to 1.9 requires a full uninstall on 1.6 and reinstall of 1.9 from yer another package repository. This is the second breaking upgrade for us with DTR.