Docker Community Forums

Share and learn in the Docker community.

Bug: Stacks associated with old non-existant node. Plus lose stackfile on terminate


(Irlagrange) #1

Hi there,

I just had some unexpected behaviour. I had created a Stackfile which worked fine. It was running. I stopped the stackfile.

I had to change my node. I created a new AWS instance. Everything went smoothly.

I tried to start my stack again. It failed. “there was no available node”. This is because it was trying to deploy to my old node, not the new one I had created.

BUG 1: Changing the node causes a stack not to start

After that, I then clicked “terminate” on the stack. To my surprise and horror, it emptied my stack file. Is this correct?

I had just made changes to it. But the whole file was gone. I had not saved it.

BUG 2: Clicking terminate wipes the stackfile.

Feature request: Version control / history on the stackfiles please.

I’d appreciate knowing whether these are actual bugs or intended behaviour. If it’s intended behabiour, then I am very surprised.

cheers,
Chris