Docker Community Forums

Share and learn in the Docker community.

Canceled build stuck

automatedbuilds
dockercloud

(Mklinkexavo) #1

We had to cancel a few builds that weren’t working due to a git force push. Now there is one build stuck after clicking cancel. New builds just get queued on top. None of the builds is actually started. This has been the case for about an hour now…

Is there a way to clear the build queue/reset the build? I have tried removing and adding the build rule for the same branch again, but this didn’t help, obviously.

On another note, it’s a paid private repository, is this really the only “support” channel?


(Mklinkexavo) #2

FWIW, I checked the build via the API, its state is ‘Canceling’. I tried to cancel again, also tried to restart both via the API. The API won’t let me fix this either. The build has been there for around 4 hours now…


(Yvanguidoin) #3

same here, was testing a new build config, I’m stuck in a cancelled state for 3 hours without any change. Also paid account and private repo.


(Lapa) #4

Same. Build was not producing any logs for 30 minutes, than I cancelled it, but now it’s just stuck in cancelling state and prevents new builds from being run.


(Lapa) #5

I also found this support article: http://success.docker.com/article/My_Automated_Build_Is_Stuck

It says to open a support ticket, however when I click on a link it doesn’t work either. So messy…