Docker Community Forums

Share and learn in the Docker community.

Cannot authenticate with the authorization server

(Taylor) #1

Started seeing a lot of this today:

Preparing to deploy...
Inspecting mcnaughton/systems-infrastructure:endpoint image in the registry
ERROR: Cannot authenticate with the authorization server
ERROR: Service Start action on 'endpoint' (using 'mcnaughton/systems-infrastructure:endpoint') has failed

I’m unable to deploy anything and without further information am pretty stuck :frowning:

Anyone seen this before and can offer a next step?

(Taylor) #2

Seeing this again but on Docker Cloud.

This was the only search result for the error message so I figured I’d document that it’s still happening.

(Bigxalx) #3

I cannot import repositories from third party registries. I tried connecting both through the web app and the docker-cloud cli. I tried to connect to a

  • self-hosted private registry
  • Azure Container Registry
  • Google Container Registry

and get the following error: “Cannot authenticate with the authorization server” (on the web app) or “Not authorized” (in the docker-cloud cli)

Connecting from the command line via “docker login” and pushing/pulling images works perfectly fine with all these registries.