Docker Community Forums

Share and learn in the Docker community.

Cannot delete repository

dockercloud

(Micahzoltu) #1

I recently migrated a bunch of my GitHub repositories over to a new GitHub organization. A side effect of this is that Docker Hub automated builds appear to be in a completely broken state. I followed the instructions online and re-linked my DockerCloud account to my GitHub Account + Organization and I can create new repositories that have auto-build working. However, I am still unable to fix my existing repositories and get auto-builds working again.

As part of troubleshoting, I tried to delete my repository and recreate it. However, when I re-create the repository after deleting it, it appears to link back to the previously existing repository! My build history comes back and worse, my auto-build configuration comes back in its still-broken state.

I really need to be able to setup automated builds for my repositories and the name must be the same. The easiest solution seemed to be just deleting and recreating all of them but that functionality appears to be completely broken.

I have tried deleting in Docker Hub as well, the same problem occurs.


(Zsolt R. Bíró) #2

it’s early 2018 and the situation is still the same. :face_with_raised_eyebrow:


(Msalvadores) #3

Same issue here. If I delete the repository and I create it again then it gets created with all the previous tags and images. There is no way to reset a repository. I have tried both via docker hub and docker cloud and same issue.


(Johnsockwell) #4

I’m having the same issue.

Has anyone found a resolution? Is there a time delay?