Docker Community Forums

Share and learn in the Docker community.

Cannot docker login after "upgrading" to Stable

I have been using Docker for Mac BETA for quite some time, but I thought it would be good to use the Stable version for now to have same versions as the rest of the development team. Everything have been working, and when installing STABLE it warned me that it will remove all content from the BETA version, and I proceeded… Looked like all is fine, but I cannot run “docker login”.

Error response from daemon: Get https://registry-1.docker.io/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

I have tried reinstall, restart, purge all, reinstall again, restart computer, restart everything, but still cannot run docker login.

Anyone with an idea what can be the cause?

Solved by removing the custom DNS servers that I use when connected to some VPN. However, strange that it doesn’t try them all… I had:

VPNDNS1
VPNDNS2
8.8.8.8
8.8.4.4

And normally dns lookup should try the servers in order, and if not accessible try the next. But it never reached the google dns…