Docker Community Forums

Share and learn in the Docker community.

Can't connect client to ucp controller cluster


(Jasonmtemple) #1

Hi,

I can’t seem to connect a client to my cluster. I have 3 server nodes running as controllers, but I am unable to get this and other nodes to connect

cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)

[root@fj-metadata01 ~]# docker run --rm -it --name ucp -v /var/run/docker.sock:/var/run/docker.sock docker/ucp join --controller-port “443” --url “https://10.1.0.116” -i --fresh-install
Please enter the URL to your UCP server: address//10.1.0.116
UCP server address10.1.0.116
Subject: ucp
Issuer: UCP Client Root CA
SHA1 Fingerprint=4A:B2:97:78:AC:22:69:FA:63:A0:84:58:67:2D:3B:DC:2D:43:FA:C8
Do you want to trust this server and proceed with the join? (y/n): y
Please enter your UCP Admin username: admin
Please enter your UCP Admin password:
INFO[0014] All required images are present
We detected the following hostnames/IP addresses for this system [fj-metadata01.censored.com 127.0.0.1 172.17.0.1 10.1.0.109]

You may enter additional aliases (SANs) now or press enter to proceed with the above list.
Additional aliases:
INFO[0002] This engine will join UCP and advertise itself with host address 10.1.0.109 - If this is incorrect, please specify an alternative address with the ‘–host-address’ flag
INFO[0002] Verifying your system is compatible with UCP
INFO[0002] Removing old UCP containers
INFO[0022] Starting local swarm containers
ERRO[0082] We were unable to communicate with proxy we just started at address 10.1.0.109. Did you forget to specify an alternate DNS server with the ‘–dns’ flag? If this address is incorrect, re-run the install using the ‘–host-address’ option. Run “docker logs ucp-proxy” for more details from the proxy
FATA[0082] Unable to connect to system

[root@fj-metadata01 ~]# uname -a
Linux fj-metadata01.censored.com 3.10.0-327.el7.x86_64 #1 SMP Thu Nov 19 22:10:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

[root@fj-metadata01 ~]# systemctl status docker
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Active: active (running) since Tue 2016-02-23 17:32:25 PST; 3h 11min ago
Docs: https://docs.docker.com
Main PID: 7910 (docker)
CGroup: /system.slice/docker.service
├─7910 /usr/bin/docker daemon -H unix:///var/run/docker.sock --exec-opt native.cgroupdriver=cgroupfs
└─8489 docker-proxy -proto tcp -host-ip 0.0.0.0 -host-port 12376 -container-ip 172.17.0.2 -container-port 2376

docker ps

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
d70f1ab9873d docker/ucp-proxy:1.0.0 “/bin/run” 3 hours ago Up 3 hours 0.0.0.0:12376->2376/tcp ucp-proxy

[root@fj-metadata01 ~]# docker -v
Docker version 1.10.2, build c3959b1

and I can connect to the host server at 443:

telnet 10.1.0.116 443
Trying 10.1.0.116…
Connected to 10.1.0.116.
Escape character is ‘^]’.
^]

(I had to change https to ‘address’ because this forum claimed I was posting too many links)

I would like to point out that firewalld is disabled on both machines


(Jasonmtemple) #2

nevermind, it was a strange problem with using servers that were upgraded from centos6 to 7. A fresh reinstall worked.