Docker Community Forums

Share and learn in the Docker community.

Can't see the # sign


(Sorcererstone) #1

Hi, newbie question. I installed Docker-for-Windows. Pulled ubuntu image. Tried to run the corresponding container by issuing the following command in powershell: docker run -it “the image id” /bin/bash
I can’t see the # sign return. I think it is hidden outside the shell display area. I know the container is running as I brought up a second shell to see what container is running. Ubuntu container is running. I only have 1 image and that is the ubuntu.

I thought the Docker-for-Windows was corrupted. So I uninstalled it. Clean out all created folders for Docker after reboot. Reinstall Docker-for-Windows (latest) again. Pulled the latest Ubuntu image. Same issue. I resized the powershell. Still cannot see the # sign even though I know Ubuntu the container is running.

I stopped and restarted Docker. Same problem.

I tried the same thing on Win8 using Docker Toolbox. I don’t have this problem.
Can someone advise me how to resolve this issue?
My OS is Win10 Pro with latest update.
Thanks in advance.


(Sorcererstone) #2

One more thing. When I used the second powershell to stop the unbuntu container, I can see the # sign return with “exit” command. It is something like this:

PS C:\Users\Sorcerer> docker run -it cd6d8154f1e1 /bin/bash
e]0;root@bba6f1d8d8a2: /aroot@bba6f1d8d8a2:/# exit

PS C:\Users\Sorcerer>