Docker Community Forums

Share and learn in the Docker community.

Can't spawn ucp (0.7.1, 0.8.0, 1.0.0, 1.0.1) on CentOS 7.2 - unable to communicate with proyx at https://host:12376

ucp
docker

(Matt Bentley) #21

OK, I’d be interested to see what happens when you use --host-address as the host’s IP address instead of hostname if you’re able to.


(Ashbyj) #22

Same result using IP for the --host-address

INFO[0048] Deploying UCP Containers
DEBU[0048] Starting KV container
DEBU[0049] Internal KV started at etcd://x.x.x.x:12379
DEBU[0049] Starting docker proxy
DEBU[0049] Proxy started on x.x.x.x:12376
DEBU[0049] Checking for liveness of https://x.x.x.x:12376
ERRO[0109] We were unable to communicate with proxy we just started at address x.x.x.x.  Did you forget to specify an alternate DNS server with the '--dns' flag?  If this address is incorrect, re-run the install using the '--host-address' option.    Run "docker logs ucp-proxy" for more details from the proxy
FATA[0109] Unable to connect to system

(Matt Bentley) #23

Any chance you could provide your routes and iptables output, specifically:

  • route
  • iptables -L

(Ashbyj) #24

Well it seems to be working now :unamused:. The puppet firewall module we use conflicts with docker’s management of iptables, and I had some purge rules that were screwing with docker. Or at least I think this is the case. Per above, I did stop firewalld and iptables completely to see if that was the issue, but I wasn’t successful in rerunning the ucp install, though I may have forgot to stop puppet which probably came back along and restored the conflicting iptables rules. I’ll let you know if I have anymore issues. Thanks Matt.


(Matt Bentley) #25

Ah great to hear! That certainly sounds plausible :slight_smile: