Docker Community Forums

Share and learn in the Docker community.

Collabora Online on Nextcloud and devicemapper


(Danjde) #1

Hi Friends,
I’m trying to enable Collabora Online on Nextcloud on a VPS Debian 9.
I’ve just try to change the device mapper storage from AUFS to devicemapper, because so seem to me to have seen, that Collabora Online need devicemapper.

Could you confirm that?

I’ve installed docker-ce from “download.docker.com/linux/debian stretch/stable”, then
I’ve try to enable devicemapper: so

#mkdir /etc/systemd/system/docker.service.d

#vi /etc/systemd/system/docker.service.d/DeviceMapper.conf
with content:

[Service]
ExecStart=
ExecStart=/usr/bin/dockerd --storage-driver=devicemapper -H fd://

#systemctl daemon-reload

#systemctl restart docker

but now obtain:

gen 18 00:33:24 server systemd[1]: docker.service: Start request repeated too quickly.
gen 18 00:33:24 server systemd[1]: Failed to start Docker Application Container Engine.
– Subject: L’unità docker.service è fallita
– Defined-By: systemd

and

docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/docker.service.d
`-DeviceMapper.conf
Active: failed (Result: exit-code) since Fri 2019-01-18 00:50:20 CET; 22s ago

Process: 1415 ExecStart=/usr/bin/dockerd --storage-driver=devicemapper -H fd:// (code=exited, status=1/FAILURE)
Main PID: 1415 (code=exited, status=1/FAILURE)
CPU: 185ms

gen 18 00:50:18 server systemd[1]: docker.service: Failed with result ‘exit-code’.
gen 18 00:50:20 server systemd[1]: docker.service: Service hold-off time over, scheduling restart.
gen 18 00:50:20 server systemd[1]: Stopped Docker Application Container Engine.
gen 18 00:50:20 server systemd[1]: docker.service: Start request repeated too quickly.
gen 18 00:50:20 server systemd[1]: Failed to start Docker Application Container Engine.

As described here I’ve try to edit /etc/docker/daemon.json too, with this content:

{
  "storage-driver": "devicemapper"
}

with the same result.

Could you suggest where I’m wrong?

Many thanks!

Davide