Docker Community Forums

Share and learn in the Docker community.

Com.docker.hyperkit up CPU to 340%


(Alexander Marchenko) #61

Yes it can take time but if try todo it ?


(Farismmk) #62

I was about to leave to go home for holiday, but I will try to remove all images and rebuild them when I get a chance. I will let you know if this resolves the issue. Thanks again!


(Alexander Marchenko) #63

sure no problem be careful, have a nice time all be ok i think


(Salv0) #64

Latest beta, still present the issue :frowning:


(Josh Reichardt) #65

Docker folks, can we please get an update on the status of this?


(Josh Reichardt) #66

I created an issue in the Docker 4 Mac github project, please help fill in any details I missed over there.


(Salv0) #67

Still no news, right? :frowning:


(Jcolemorrison) #68

Has anyone had any success switching back to Docker Toolbox?


(Robertdavid010) #69

Confirming I am having this issue on current local dev stack.

Mac OS El Capitan

Docker with one Node instance
React Native App
Django Backend
Postgres DB

Is a fresh install of docker GUI from official source.

Have to fix this for current work project. Makes the OS very sluggish.

com.docker.hyperkit - stays at ~130% CPU
com.docker.oxsfs - stays at ~ 60% CPU

This is not tolerable in a professional dev setup IMO.


(Hmottestad) #70

I’m on “Version 17.03.1-ce-mac5 (16048)” and I’m also getting 200-400 % CPU while docker stats shows that nothing is happening.


(Dan Levy) #71

@hmottestad This was my fix on same version:

sudo tmutil disablelocal

I luckily had avoided the issue the last few months - well until v17.03 - since it’s been randomly maxing my CPU to the point my keystrokes were slow or skipped - it felt like the systems’ IRQ scheduler went for one too many rides on a tilt-a-whirl ‘spinning teacup’ ride - missing input/output data. Nothing responds with grace, all dis-coordinated all over the screen. :laughing:

Anyway, here’s some due credit:
My fix was found by way of these 2 amazing answers on Stack Overflow:

an amazing list of OSX diagnostic tools/cmds
and
this happened to include my fix

These are things I can barely fake knowing - assuming a linux kernel, and admittedly with much fancier tooling.

https://github.com/kenorb :heart: :heart: :heart:

Honestly I learned more solid tech details in the last 15 minutes - compared to all time I spent in 2016 wading through the endless SO Anti-patterns Museum.


(Justin Swan) #72

I had been starting docker via iTerm2 and was experiencing the same issue, I have since switched to using Terminal and CPU % has dropped to 80%. Might be something to do with the way I’ve set up iTerm2 but this may help someone.

Edit - have just gone back to iTerm2 after deleting preferences file com.googlecode.iterm2.plist could well have been due to oh-my-zsh.


(Patrickbassut) #73

For me, after adding :cached to all the volumes in use, it dropped to like 5%.

If you’re using docker-compose, it’s as simple as:

  image-api:
    image: mygroup/image-api:latest
    volumes:
      - ./api:/var/www/beta/api:cached
      - ./web:/var/www/beta/web:cached

(Mstahlmann) #74

I had this issue. I was using nodemon to monitor my changes in a local dev container. I switched to PM2 instead. I have been using pm2 monit to see the logs and pm2 restart allows me to hot swap in changes. Not quite as convenient as the automatic process of nodemon but my cpu load is down to a minimum. Mine was up at 340% and I am running 8 cores.


#75

Each Docker monitoring process increase this CPU load.
For sample, if you use Visual Studio Code with docker explorer monitor, update the Auto Refresh Interval to a higher value like 2000.


#76

Are you running Webpack?
Open up webpackDevServer.config.js
edit line 69, change true to 1000.

watchOptions: {
ignored: /node_modules/,
poll: 1000
},