Docker Community Forums

Share and learn in the Docker community.

Com.docker.osxfs is not running


#1

Expected behavior

Expect docker to start

Actual behavior

Docker does not start with below error in diagnosis

Information

Docker for Mac: version: mac-v1.11.2-beta15
OS X: version 10.11.5 (build: 15F34)
logs: /tmp/20160617-153826.tar.gz
failure: com.docker.osxfs is not running
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[ERROR] osxfs
com.docker.osxfs is not running
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[ERROR] moby
/Users//Library/Containers/com.docker.docker/Data/com.docker.driver.amd64-linux/console-ring does not exist
[OK] driver.amd64-linux

Steps to reproduce the behavior

  1. Stat docker

(David Sheets) #2

Hi Philip,

Could you please post your diagnostic id so I can take a look at your logs?

Thanks,

David


#3

diagnostic id: 57E69510-531D-4B38-821D-6C9ED2C59ACC


(Lyleh) #4

I’m experiencing something similar on 1.12.0-rc2-beta16: 1C64D55C-92AC-4073-A5EB-107F9706E063


(Lyleh) #5

After performing Preferences -> Uninstall/Reset -> Reset to factory defaults, Docker restarted and works normally.


#6

Reset to factory defaults worked for me too but only if I choose not to import existing images.

Thanks!


(Robert Lemke) #7

Same here: After upgrading to 1.12.0-rc2-beta16 Docker won’t come up again, Com.docker.osxfs is not running.
My diagnostic id: 00B15F8F-8B3C-417D-8F86-25EAA418D73F

Resetting to factory defaults solved it for me, too.


(Morettoni) #8

Same here in my mac, my diagnostic id 284D829B-3A5C-4B4A-971C-8789FEE61480
Hope it will be fixed soon, actually the only way to have it running again is to reset Docker…