Docker Community Forums

Share and learn in the Docker community.

Compatibility matrix for

Hi Docker team,

Can you please confirm if the Compatibility Matrix - https://success.docker.com/article/compatibility-matrix#docker1803eeengine is also valid for the below versions:

Version: 19.03.2 and RHEL 7.7

Your post is missleading. Your link posts to the standalone engine 18.03 EE. The version you provide is 19.0.3.2.

The compatibility matrix lists different Docker Enterprise target versions, each with different minimum versions of the the engine for os’ses.

I am sorry if my post led to any confusion. All I am asking is that the link https://success.docker.com/article/compatibility-matrix#docker1803eeengine doesn’t talk specifically about version 19.03.2 and RHEL 7.7 which my team is using.
We have to be very sure that when the Compatibilty Matrix says “and higher” under Column “Enterprise Engine”, does it cover my versions too?
Furthermore, the link doesn’t talk about the file system extFS which we are using.

The compatiblitiy Matrix lists compatiblity per product release:.
– Docker Enterprise Edition 3.0
– Docker Desktop Enterprise 2.1
– Docker Enterprise Edition 2.1
– Docker Enterprise Edition 2.0
– Docker 18.03 EE Engine
– Docker Enterprise Edition 17.06 and earlier

The product “Docker 18.03.EE Engine” is restricted to the engine 18.03.x releases. It is a special “product” because it does not include UCP and DTR.

Docker Engine 19.03.2 Enterprise on RHEL7.7 is compatible with:
– Docker Enterprise Edition 2.0
– Docker Enterprise Edition 2.1

Docker Enterprise Edition 3.0 requires at least 19.09.3 on RHEL7.7.

If you only use the bare naked Docker Engine and you never plan to install UCP and DTR, You should be still entitled for support, as long as you use Docker Engine starting with 17.06.2-ee-24.

Though, this one is a party breaker:

This is a support matrix! Whatever combination is listed is supported. Whatever is missing is not supported…