Concourse - waiting for docker to come up

I’m following a course on Pluralsight and haven’t been able to continue because of this error
Basically I get spammed with waiting for docker to come up for 2 minutes until it finally gives up and I get a huge error log which you can see on the hastebin link below.

I’ve tried everything that there is to find in google. At this point I’m going crazy and I would really appreciate the help.

I’ve already tried deleting docker, restarting my pc and reinstalling.
I’ve already tried deleting the info from %appdata% for both docker and docker desktop.

Not running on any VPN.
I have WSL to run with Google’s DNS.

Concourse Image

After failing, it says image fetching failed

I’m only allowed to paste up to 2 links since I’m new but all of them are here(logs, dockerfile, pipeline).

I can’t see the course since it is not public, but it looks like you are following something very similar to the official quick start guide: Quick Start - Concourse CI

To be honest, I don’t see what it is waiting for, but the fact that you are using Docker Desktop can make it more difficult to use “containerd” as a worker runtime. Did you try it directly in WSL without the desktop?