Docker Community Forums

Share and learn in the Docker community.

Configure Cloudstor to use SMB 3.0?


(Aguzman) #1

Hello,

The documentation for the cloudstor plugin in Azure is a bit sparse, and I haven’t been able to find a way to force the plugin to use SMB 3.0.

Does anyone here know the secret sauce to configure the SMB version?


(Deep Debroy) #2

@aguzman any specific reason you are looking for SMB 3.0? The linux kernel support for SMB 3.x is still maturing [https://wiki.samba.org/index.php/SMB3_kernel_status] and I ran into issues when mounting FileStorage over SMB 3 on Linux. That is why we released with SMB 2.1 hardcoded. Also are you using our Moby Linux VHDs or your own OS for the hosts?


(Deep Debroy) #3

I guess we can add it as part of https://github.com/docker/for-azure/issues/28


(Aguzman) #4

@ddebroy The reason we need SMB 3.0 is that our network situation makes access the Azure Storage using the public IP address and this requires SMB 3.0, or so I’ve been told.

We are using centos for our OS.

I would love to use the Docker CE template, but it deploys using a Public IP. We need to deploy to an existing vNET. Any pointers to modifying the template or adding an option to use existing vNET would be great!

Thanks!


(Aguzman) #5

I agree with issue 28, adding more options to the driver at mount time would be very useful.


#6

I realize this is an old thread but still no solution for this?
It seems that using a secure connection to Azure Files would be a requirement in most if not all environments.

It works fine if you mount the Azure Files share on all the nodes in a swarm and mount using the ver=3.0 option

These days most of the major Linux distributions support SMB 3.0 encryption.