Docker Community Forums

Share and learn in the Docker community.

Connecting Docker Cloud to AWS: Invalid AWS role or insufficient permissions


(Sfkiwi) #1

I am new to Docker and attempting to set up for the first time. I have followed the documentation for connecting AWS credentials to Docker account to the letter as far as I can tell however when I try to add the ARN to docker I get the error message "Invalid AWS role or insufficient permissions".

I found a couple of other posts related to this. The first one had this problem because payment details on AWS were not up to date. I have made sure that AWS has up to date payment details and a valid credit card on file.

I have added the new role for Docker Cloud and added the inline policy per the Docker information and finally copied the ARN into the AWS credentials on Docker Cloud Settings.


(Xazoola) #2

hey sfkiwi, have you found the reason for this error? I am having the same problem. For me, Everything AWS account related is fine. I can list the Role using the AWS-Cli and my External ID for Docker Cloud is fine as well. At this point I an only think that this thing is buggy and not ready for any type of real use. Please let me know if you have or have not found a solution. Thanks for answers you may or may not have.


(Sfkiwi) #3

No unfortunately I never managed to resolve this. I was just starting to explore Docker but didn’t have an immediate need and troubleshooting this problem was wasting too much time. I’ve gone through all the settings in my AWS that I thought might be related and retried the integration on Docker Cloud a bunch of times. Despite following the instructions exactly I’m still getting the same message. I’m just now sure how to troubleshoot it. Would be nice to have some further information about the error.


(Xazoola) #4

thanks for your reply. I still have not figured this out. extensive googling provided nothing as well. If I ever do find how to get this working I will post back. Thanks for the info.


(Michaelmafort) #5

I saw that if you give the AdministratorAccess in Policy the Docker Cloud create the Cluster nodes, but AdministratorAccess is too much permission that you need.


(Iostream82) #6

Any news?, i got the same issue, it’s possible the problem is due the free tier?


(Sdlmer) #7

I got the same issue.
Try to use custom policy, like this.
Read this, and make for a key for each region.
But result does’t change.

No matter what I type in field “External ID”, result does’t change.

How can I check that “Your AWS account must support EC2-VPC” ?