Docker Community Forums

Share and learn in the Docker community.

Copying an Excel file Jupyter Notebook on Ubuntu 18.04

I am trying to get a Excel sheet into a jupyter notebook. I need the data that is on it to run a machine learning program. I have so far been unsuccessful.

When I tried importing it using the import command in the in the upper right hand corner of the jupyter notebook (see first attached image) it either would not import or if it did import it gave a short message that the file cannot be imported because it it not UTF-8 encoded.

I then decided to try the simple Docker cp command and got the error the you see on second attached image.

How can I get this Excel file into to my Jupyter Notebook that is running on Ubuntu 18.04? I have tried two different ways that have worked for other files, but not for an Excel file.

Any help appreciated. Thanks in advance.

Respectively

I just realized that I cannot attach images in this forum. I think that you still get the idea of my question. I need to put an Excel file and its data into my Jupyter Notebook that is running on Ubuntu 8.04.

I have tried two different ways and each failed. How do I do it?

I “presume” that you run “CE” (Community Edition) of docker … no ?

If so, you’ll need to execute the “copy command” aus user root:

docker cp myExcelFile.xlsx containerID:/path-where-the-file-should-be-placed

I am running Docker CE. I tried the format that you said, it works on all files except Excel. It does not work on Excel. If I could post a picture of it, I would, with the error shown. I am guessing it might be as simple as the filename has a space in it or that the Excel file format is not acceptable to Jupyter Notebook on Ubuntu 18.04.

Is there a way that i could get a picture to you to you this? It is easier to show you than to discuss it in writing.

The bottom line is that I used the command that you cited, but it will not work on an Excel. Could it be something as simple as the space in the file name?

Respectfully,