Docker Community Forums

Share and learn in the Docker community.

Device files missing when I use any rhel image but visible in any ubuntu image


(Gur13351) #1

Tried multiple images ( Ubuntu and Rhel ) .

when I look into /dev directory of Ubuntu container , I can see -

> agpgart console fd loop1 loop7 midi03 mixer2 ptmx ram11 ram2 ram8 rmidi3 smpte3 tty0 tty6 audio core full loop2 mem midi1 mixer3 pts ram12 ram3 ram9 sequencer sndstat tty1 tty7 audio1 dsp fuse loop3 midi0 midi2 mpu401data ram ram13 ram4 random shm stderr tty2 tty8 audio2 dsp1 kmem loop4 midi00 midi3 mpu401stat ram0 ram14 ram5 rmidi0 smpte0 stdin tty3 tty9 audio3 dsp2 kmsg loop5 midi01 mixer null ram1 ram15 ram6 rmidi1 smpte1 stdout tty4 urandom audioctl dsp3 loop0 loop6 midi02 mixer1 port ram10 ram16 ram7 rmidi2 smpte2 tty tty5 zero

This is fine but when I see the content of /dev in Rhel -

console full fuse kmsg null ptmx pts/ random shm/ tty tty1 urandom zero

I have not tried anything special with Ubuntu image.

docker run -i -t rhel /bin/bash
docker run -i -t ubuntu-12.04 /bin/bash

How can I have an rhel 6.5 image with these file in /dev directory


(Sven Dowideit) #2

This would be a question you need to ask the maintainers of the RHEL images (ie, Redhat), and I’m sure they’ll ask what you need them for too :slight_smile:


(Gur13351) #3

Thanks … but I tried the same … from an iso and qcow2 image I had , but it never makes those directories.


(Sven Dowideit) #4

@lsm5 can you please get whoever’s responsible for the redhat docker images to document why this image is different to all others, and how users that need more can make a more functional image?


(Václav Pavlín) #5

Hi, I maintain RH base images at the moment. As Sven predicted, I need to ask - what do you need them for?:wink: Also keep in mind that Ubuntu and RHEL (which is the origin for the image) are quite different distributions so there might be differences between them. Let me know about your use case and we can figure it out.


(Gur13351) #6

Hi,

I need to install a software on it. It access the /dev/mem files. So , it was giving some errors. Thats the reason I am looking for this.

I tried building my own docker image from rhel. Still I cannot find them.
I tried mapping them to my host machine ( -v /dev:/dev) but after that I am facing a new problem while installation of my software -


INFO: Starting xinetd service…
Starting xinetd: [ OK ]
Reloading configuration: [ OK ]
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

I donot know why its showing “ubuntu” when I am using redhat.
Also I searched for this on red hat site and found a bug related to this issue , but could not find any solution or workaround.