Dial tcp: lookup localhost on [::1]:53: dial udp [::1]:53: socket: operation not permitted

I have one application which run successfully in pure ubuntu file system.
then, I tar this ubuntu root file system and import it to docker image, then run the docker image.
however, when I run my application in docker container, I got the below error:
Post http://localhost:8000/2016-11-01/cloudwatch/logs/: dial tcp: lookup localhost on [::1]:53: dial udp [::1]:53: socket: operation not permitted

I searched this issue via google, but I don’t find the solution.
Appreciate for any cue how to fix this issue!
thanks a lot.

below is the sequency to setup docker image and container:

  1. tar the root file system (for example: rootfs.ggc.tar) in which the application can run successfully
  2. import this tar archive to docker image:
    cat rootfs.ggc.tar | docker import - docker.ggc
  3. get the image ID (for example: 845283a6bc4f) with command “docker images”
  4. run docker container with below command (for example: 845283a6bc4f):
    docker run --privileged -ti 845283a6bc4f /bin/bash
  5. now enter the container prompt, start the application.

below is my docker information:

docker info

Containers: 32
Running: 1
Paused: 0
Stopped: 31
Images: 2
Server Version: 1.12.6
Storage Driver: overlay
Backing Filesystem: extfs
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: null host bridge overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options: seccomp
Kernel Version: 4.4.65-dirty
Operating System: Ubuntu 16.04.2 LTS
OSType: linux
Architecture: aarch64
CPUs: 4
Total Memory: 7.727 GiB
Name: localhost
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
WARNING: No cpu cfs quota support
WARNING: No cpu cfs period support
Insecure Registries: