Docker Beta for Mac does not work and hangs frequently on macOS 10.12

Expected behavior

docker pull ubuntu should pull the correct image.
docker ps -a should list all containers

Actual behavior

docker pull ubuntu
Using default tag: latest
latest: Pulling from library/ubuntu

90d6565b970a: Extracting 15.2 MB/49.26 MB
40553bdb8474: Download complete
c3129e7479ab: Download complete
091663bd70db: Download complete

All Docker commands hang.


  • the output of:
    • Moby Menu > Diagnose & Feedback on OSX: C4E070E0-ED5C-405F-A950-14F33BF29B4C
  • host distribution and version ( macOS Sierra Beta 10.12)

Steps to reproduce the behavior

  1. Upgrade to macOS Sierra Public Beta
  2. Try creating a new container
  3. Try pulling any new image
  4. Try docker ps -a
  5. Reset Docker
  6. Reinstall Docker
  7. Same issue persists

I’m same problem,

Docker for Mac: version: mac-v1.12.0-beta18-3-gec40b14
OS X: version 10.12 (build: 16A239j)
logs: /tmp/20160713-213240.tar.gz
failure: docker ps failed: Failure(“docker ps: timeout after 10.00s”)
[ERROR] docker-cli
docker ps failed
[OK] app
[OK] menubar
[OK] virtualization
[OK] system
[OK] osxfs
[OK] db
[OK] slirp
[OK] moby-console
[OK] logs
[OK] vmnetd
[OK] env
[OK] moby
[OK] driver.amd64-linux

Diagnostic ID:

➜ luk4z7 docker --version Docker version 1.12.0-rc3, build 91e29e8, experimental

➜ luk4z7 sw_vers ProductName: Mac OS X ProductVersion: 10.12 BuildVersion: 16A239j

Same here, hangs frequently.

$ docker --version Docker version 1.12.0-rc3, build 91e29e8, experimental

And, macOS Sierra 10.12 Beta
$ sw_vers ProductName: Mac OS X ProductVersion: 10.12 BuildVersion: 16A238m

This is what can happen when running beta software on a beta OS though.

Diagnostic ID C15DF67E-9046-458E-9EB8-00DB1442CEEE

I have restored El Capitan on the computer. This beta did not work out for me very well.

Same issue for me

  • Docker hangs
  • macOS 10.12
    *Version 1.12.0-rc4-beta19 (build: 10258) c84feba3aa680f426b8fa66f688388611267cd53

$ docker pull sepulworld/aptly-cli
Using default tag: latest

hangs there

Try disabling ntpd:

sudo launchctl unload /System/Library/LaunchDaemons/org.ntp.ntpd.plist


Can confirm disabling ntpd fixes issues on latest (experimental) docker version 1.12.0-rc4 and latest MacOS Sierra Beta 10.12 Beta (16A239j)

1 Like

Can also confirm that disable ntpd helps. Any idea why?

I can also confirm that disabling ntpd works.

This (disabling ntpd) made docker Mac started successfully but I’m still having problem running docker run or docker build. It just got stuck there. Anyone has same issue?

I disabled the NTPD and worked

Disabling NTPD appears to have resolved all my issues with Version 1.12.0-rc4-beta19 (build: 10258) on 10.12 Beta (16A238m)

In my another mac, disable ntp does not fix the issue. docker is always in starting mode.

docker: 1.12.0-rc4-beta20 (build: 10404)
10.12 Beta (16A238m)

After all attempts, tried reset to factory defaults and it works with ntp disabled again. Finally.

There is one ticket is open. I am not sure it is related.

So this has worked successfully for me too. The question is why? Is org.ntp.ntpd.plist called the same in previous OS builds? And digging further - if it’s causing the hang - then it’s probably related to the vmnet or something in hypervisor / moby not being able to sync with the time maybe?

disabling ntp worked for me too. thanks