Docker CE Stable isn't updating (loop)

Hello there,
I currently own a always free ressource VPS at Oracle Cloud and everything worked like butter on bread with Docker for my website and such. However 3 days ago I just logged on SSH to update my server but when I run the command >sudo dnf update I always end up with this in loop with no updating at all. I tried removing Docker and reinstalling and now it’s even worse it gives the same thing.

Docker CE Stable - aarch64 [ === ] — B/s | 0 B --:-- ETA
Does anyone know how to fix this?

The VPS is running on Oracle Linux 8 build version 2022.05.30-0

Docker does not maintain the docker package for Oracle Linux. You might want to check who the maintainer is and ask them directly or if there is a Oracle Linux forum, preferably post it there as it is more likely that people in an Oracle Linux forum use the docker package than docker users here that use Oracle Linux.

Before your ask: I have no idea who the package maintainer for Oracle Linux is - probably its Oracle itself.

It looks like dnf can’t update the repository cache because of a network or DNS issue. Oracle Linux is based on Red Hat like CentOS, so you probably use this repo (but check if I am right):

Try to use curl to access that url. It should work.

You can also try to remove the repository and run dnf update again to see if you can update anything. Check your system logs too. If it is not a network issue, then as @meyay suggested, you should ask the maintainer of Oracle Linux or the Oracle Linux community.