Docker Community Forums

Share and learn in the Docker community.

Docker Centos inside open stack guest VM

docker

(Svelatt) #1

Hi Below is my Infra where I am trying out docker.

Internet >>> Sonicwall >> Openstack Host >> Centos VM(where docker service is running)

I tried starting a Centos docker container using command docker run -ti centos:latest bash

when I run yum update it fails saying too slow. I tried pinging the url give by yum it pings. I tried running curl on the url given . The output is below

  • About to connect() to 108-43-236-85.rev.customer-net.de port 80 (#0)
  • Trying 85.236.43.108…
  • Connected to 108-43-236-85. rev .customer-net. de (85.236.43.108) port 80 (#0)

GET / HTTP/1.1
User-Agent: curl/7.29.0
Host: 108-43-236-85 .rev.customer-net .de
Accept: /

… This timeout here

now when I try my intranet sit it give be response

  • About to connect() to xxx.yyyy…com port 80 (#0)
  • Trying 172.16.1.13…
  • Connected to xxx…yyyy…com (172.16.1.13) port 80 (#0)

GET / HTTP/1.1
User-Agent: curl/7.29.0
Host: xxx…yyyy…com
Accept: /

< HTTP/1.1 302 Found
< Date: Wed, 11 Jul 2018 16:07:58 GMT
< Server: Apache/2.4.6 () OpenSSL/1.0.2k-fips PHP/5.6.32 mod_perl/2.0.10 Perl/v5.16.3
< Location: https:// xxx…yyyy.-com/
< Content-Length: 214
< Content-Type: text/html; charset=iso-8859-1
<

302 Found

Found

The document has moved <"https: //xxx..yyyy. ..com/">here.

* Connection #0 to host xxx.yyyy.com left intact

NOTE: I HAVE EDITED THE URL PARTS

any help is this matter is highly appreciated