Docker Community Forums

Share and learn in the Docker community.

Docker Cloud build failing without log

docker
dockercloud

(Micahzoltu) #1

I have a repository that I just pushed a minor change to. The docker image builds fine locally (Docker for Windows) and takes quite a few minutes. Docker Cloud, which is setup to auto-build on commit to master, attempts to build it and fails within a second or two. When I try to look at the logs for the build, it just says “Waiting for logs…”. As far as I can tell, I have no further troubleshooting details. I have the option to Retry the build but that just repeats the failure. According to the timeline, the build failed in under 1 second.

What can I do to troubleshoot this issue further?


(Micahzoltu) #2

Possibly of note, I am trying to build with “Use my own nodes”. The repository is in my organization and I am logged in as an organization owner. Just before this failure started occurring, I moved all of my nodes/clusters/services from my personal account to the organization account. I actually don’t know how the build worked before, since the organization (which is what the repository is associated with) didn’t have any nodes. Now it does have nodes and I (personal account) don’t.


(Micahzoltu) #3

Switching the build to “Build on Docker Cloud’s infrastructure” resolved my issue, but I want to build using my own nodes. What do I need to do in order to get this functionality back?

Why did it break when I moved my nodes to the organization account?

How do I add a “builder” label to a node cluster (found some instructions online that recommend that)?


(Pablo Chico de Guzman Huerta) #4

@micahzoltu Hi there and sorry for this inconvenience,
We have some known issues for organization repositories whose autobuild was created from a personal account first. These autobuilds keep building in the personal account nodes instead of building in the organization nodes (as they should). The reason for this ambiguity is that we don’t want to break existing autobuilds that are running in personal account nodes. We are working in a migration path which will be soon available. For the moment, I can update your autobuilds if you give me the affected repository names.
Respect to the empty build logs, I have identified a regression related to this. It will fix in production in a few days.


(Pablo Chico de Guzman Huerta) #5

Also, for now, you could create builder nodes in your personal account and it would work.


(Davidthornton) #6

I believe I might be affected by this issue as well. Has any progress been made on the issue?

If I retry the builds, they succeed.


(Xemasiv) #7

In my case it’s my browser’s ad-blocker that’s preventing me from seeing my logs. e.g. Ad-block, uBlock, etc.


(Davidthornton) #8

What is specifically being blocked, do you know?


(Xemasiv) #9

The logs.

Wasn’t really sure anyway, there were even tines that I aint got no
adblockers on but the logs were still delayed.


(Davidthornton) #10

Ahh ok, do you know which HTML elements were being blocked? I haven’t seen any speedup at my end!


(Pauliusmacernis) #11

Same here with Firefox 59.0.2 (64-bit) on Ubuntu 17.10.
Disabling Adblock Plus (https://adblockplus.org/en/) solved the issue for me.

The following may be related:
I had another issue when signing up to Docker Cloud (https://cloud.docker.com/) just few minutes ago. I was using the same Firefox and was not able to Sign Up (nothing happened when I clicked “Sign Up”) back then. However, Chrome 66.0.3359.117 (Official Build) (64-bit) went fine for me. My Chrome does not have the Adblock extension.

Update:
Not sure if I still have the logs issue. It seems the process just takes some time to start and finish. It may be so that I accidentally hit the same “finish” moment by disabling the addon on Firefox. Anyways, the bug when signing up was real.