Docker Community Forums

Share and learn in the Docker community.

Docker Cloud CLI Incompatible with PyYAML >=5

I am trying to setup docker-cloud cli and it has an incompatibility with PyYAML >=5

Is there any way around this as PyYAML = 5.4.1 right now and needed by other tools I am using.
It is also dependent on cryptography, and OCI-CLI (Oracle Cloud) which oci installs a later version of.

But even with PyYAML 3.13 I am not able to run it as below, while OCI-CLI runs ok even with the changes.
Will there be a fix for this soon in upgrading to latest PyYAML?
Thank you for your help and suggestions!

Output on install: sudo pip3 install docker-cloud.
Processing /root/.cache/pip/wheels/db/f2/07/5e58b12bc11255c3fc0a0aca89849050a8ec203d8b4a3c52c0/PyYAML-3.13-cp38-cp38-linux_x86_64.whl
ERROR: oci-cli 2.21.1 has requirement cryptography==3.2.1, but you’ll have cryptography 2.9.2 which is incompatible.
ERROR: oci-cli 2.21.1 has requirement PyYAML==5.1.2, but you’ll have pyyaml 3.13 which is incompatible.
Installing collected packages: PyYAML
Attempting uninstall: PyYAML
Found existing installation: PyYAML 5.4.1
Uninstalling PyYAML-5.4.1:
Successfully uninstalled PyYAML-5.4.1
Successfully installed PyYAML-3.13
vagrant@vbUBUNiINFRA1:~$ docker-cloud -v
Traceback (most recent call last):
File “/usr/local/bin/docker-cloud”, line 5, in
from dockercloudcli.cli import main
File “/usr/local/lib/python3.8/dist-packages/dockercloudcli/cli.py”, line 10, in
from dockercloudcli import commands
File “/usr/local/lib/python3.8/dist-packages/dockercloudcli/commands.py”, line 15, in
from dockercloudcli import utils
File “/usr/local/lib/python3.8/dist-packages/dockercloudcli/utils.py”, line 16, in
from exceptions import BadParameter, StreamOutputError
ModuleNotFoundError: No module named ‘exceptions’

Mono