Docker Community Forums

Share and learn in the Docker community.

Docker-cloud stack ls

teamsorganizations

(Vanderkerkoff) #1

Afternoon all

We’re in the middle of the lovely process of manually moving our repositories from a single user docker hub account, to our organisations account, thats not so bad.

The next extremely unpleasant bit is moving all the nodes and stacks and all that stuff over to our organisation.

It’s pretty painful, but moving along.

I’ve just run into a problem.

When I run docker-cloud stack ls, as the user who is an owner of the organisation, I’m still not seeing any of the stacks or services that are on our new organisation, only the ones that are left in my personal docker cloud.

I’ve tried docker logout and login again, no joy.

Can someone tell me how I get to use the docker-cloud cli on the organisations elements?

I don’t mind if I can’t use it against the personal one again, we’re moving all that over to the organisation anyway.


(Lee Hull) #2

Make sure once you login, you choose the organization from the dropdown under your name in the top right corner


(Vanderkerkoff) #3

Hi @lhull Sorry, maybe I wasn’t clear.

I’m using the docker-clound cli from the command line.

I’m thinking that maybe there should be an option when your logging in of supplying an organisation name, or maybe even using your organisation name instead of your username.

Thanks for replying though


(Lee Hull) #4

You can use a namespace to specify the organization

export DOCKERCLOUD_NAMESPACE=yourteam