Docker Community Forums

Share and learn in the Docker community.

Docker commands running slow

All docker commands are running slow (e.g., ps, logs)

Docker Toolbox
Windows 10
VirtualBox default set to 2 CPUs

I’m on a weak wi-fi network, but don’t need to download anything. My app itself is running fine.

$ docker -D info
Containers: 17
Running: 14
Paused: 0
Stopped: 3
Images: 60
Server Version: 18.03.0-ce
Storage Driver: aufs
Root Dir: /mnt/sda1/var/lib/docker/aufs
Backing Filesystem: extfs
Dirs: 159
Dirperm1 Supported: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: bridge host macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file logentries splunk syslog
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: cfd04396dc68220d1cecbe686a6cc3aa5ce3667c
runc version: 4fc53a81fb7c994640722ac585fa9ca548971871
init version: 949e6fa
Security Options:
Profile: default
Kernel Version: 4.9.89-boot2docker
Operating System: Boot2Docker 18.03.0-ce (TCL 8.2.1); HEAD : 404ee40 - Thu Mar 22 17:12:23 UTC 2018
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 9.514GiB
Name: default
Docker Root Dir: /mnt/sda1/var/lib/docker
Debug Mode (client): true
Debug Mode (server): false
Experimental: false
Insecure Registries:
Live Restore Enabled: false


Hi, I have the exact same issue. Did you happen to resolve this? I’m at a loss. I think it’s somehow related to networking because if log into the boot2docker vm the responses are quick.

> docker-machine ssh default
> docker ps -a

Have you tried doing that?

Same issue here. Even docker -v consistently takes 17 seconds when my host Windows 10 laptop is connected to the network via Wifi. As soon as I disconnect from that wireless network, or turn-off Wifi, the operations are instant. Even the Tray Icon takes 15 seconds for the menu options to even come up. Same behavior for both Linux container or Windows container mode.

An example …

PS C:\dev> get-date;docker -v;get-date

Saturday, September 8, 2018 8:35:40 AM
Docker version 18.06.1-ce, build e68fc7a
Saturday, September 8, 2018 8:35:56 AM

This posting on github pointed me to the solution. As noted above, I originally thought it was due to me being on wireless because the commands would execute quickly when I disconnected wireless. I finally had a chance to connect to my ethernet from home and had the same problem.

After the github posting, I connected to corp via our VPN and the Docker commands then executed MUCH more quickly. There is still a minor one second-ish delay, probably due to latency of the domain controller calls, but that’s all.

1 Like

@caseychamberlain, But I don’t get it. What is the solution? Obviously I’m not expected to VPN into your corp network. How can I and others take advantage of this solution?

@wyckster, if your situation is similar to mine, then connecting to your corporate VPN when outside of that network, could resolve the problem.

Hi @caseychamberlain, Are we unable to use other network except the corporate network?

I also met same issue with docker cli. I realize that when I change to use my personal hotspot wifi, docker-cli reponses instant. But the same thing does not happen on my home wifi network.

I think we need a clearly solution for this issue.

1 Like

PS C:\Users\mdeignan> get-date;docker -v;get-date

Friday, May 24, 2019 7:55:35 AM
Docker version 18.09.2, build 6247962
Friday, May 24, 2019 7:56:44 AM

Docker commands take eons regardless of what network – wifi or hard-wired ethernet – I am connected to.

Would appreciate tips on how to solve this, 1+ minute execution times make the product virtually unusable.

disabling IPv6 solved my issue.


Any command is preceded by 14 seconds of apparent inactivity.
This happens on Windows.

$ date && docker --version && date
Wed, Oct 09, 2019 8:29:22 AM
Docker version 19.03.1, build 74b1e89e8a
Wed, Oct 09, 2019 8:29:36 AM

Any help is much appreciated.

Any new/updated resolutions to the ‘lack of speed’ issue?

Helped me, disabling IPv6 in every Network Adapter under Windows and every docker command runs fast. I don’t know what I can say to this …

You can try this one. It solved my issue.

Its working for me also
i connected to my company network via vpn and it worked