Docker Community Forums

Share and learn in the Docker community.

Docker container exited with code 132

Hi, I need your help from all of you guys. When I ran the mongo container on server A with OS Ubuntu 20.04Lts, it’s been always exited with code 132. however, I can successfully be running that container on other servers. Do you know what’s the problem? I have tried to uninstall docker clearly and reinstall but the error still occurs. I also already ran the command “docker system prune --volumes” to clean all cache and data, but it seems unuseful for me. Can anyone give me good solutions to solve this problem?
thanks and regards

Good morning,
have the same problem (see Mongo:latest does not start on missing sse4_2) with mongodb:latest (which is version 5). Running the older (and still maintained) version 4 the container is starting fine.
I guess that the v5-image refuses to start due to missing features on the CPU as mongodb ends with “illegal instruction”.
There is already an issue for this on github:

Quick way to solve it is to use the image mongodb:4 instead of mongodb:latest