Docker Community Forums

Share and learn in the Docker community.

Docker Deskto for WIndows (42716) fails to update/fails fresh install

The last three updates have failed? I am unsure why I still try? Hoping one day a working release will be pushed out. At least this time the uninstall still works. The previous two updates required a shell script to uninstall and cleaning the registry. Please release an update that installs/upgrades/works. Please stop pushing out releases that don’t work at all. The last working version I have is

Does anyone read these posts besides end users?
This is the second time posting here and I don’t see any response other than "yeah, it’s broken for me too… "

Oh, also the edge version fails in the exact same way version

One or more errors occurred.
   at Docker.Core.Pipe.NamedPipeClient.<TrySendAsync>d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at Docker.Core.Pipe.NamedPipeClient.Send(String action, Object[] parameters)
   at Docker.Actions.DoStart(SynchronizationContext syncCtx, Boolean showWelcomeWindow, Boolean withNotifications)
   at Docker.Actions.<>c__DisplayClass26_0.<StartAsync>b__0()
   at Docker.ApiServices.TaskQueuing.TaskQueue.<>c__DisplayClass18_0.<.ctor>b__1()

  One or more errors occurred.
     at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
     at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken)
     at Docker.Backend.LifecycleClient.DockerStart()
     at Docker.Backend.ContainerEngine.Linux.DoStart(Settings settings, String daemonOptions, Credential credential)
     at Docker.Backend.ContainerEngine.Linux.Start(Settings settings, String daemonOptions, Credential credential)
     unable to fetch daemon.json: Get http://unix/engine/daemon.json: net/http: request canceled (Client.Timeout exceeded while awaiting headers)
        at Docker.Backend.HttpClientExtensions.<ParseResponseBodyAsJsonAsync>d__2`1.MoveNext()
     --- End of stack trace from previous location where exception was thrown ---
        at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
        at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
        at Docker.Backend.HttpClientExtensions.<GetJsonAsync>d__0`1.MoveNext()

+1: I have the exact same issue. Tried uninstalling and deleting everything to no avail.
Please post if you find a solution! :stuck_out_tongue:

Same issue here. Do you have a link to the last version that works?

Any update still failing :frowning:

Disabling the linux subsystem in windows resolved the issue for me.

2 Likes Install worked! I did take @nicholasrichter advise and turn off Linux subsystem. Unsure if this was a factor, but thank you Nicholas! Anyway, super happy to be on latest version and that the install worked

same issue here.
I disabled linux subsystem like @nicholasrichter and it works now.

I’m running a VM Windows 10 on Virtualbox on a Windows 10 Host with intel CPU.