Docker Community Forums

Share and learn in the Docker community.

Docker Desktop always starts although disabled

Same problem here :frowning:

on Windows 10 Pro 1803:
Version (29211)
Channel: stable
Build: 4271b9e

Same here:

Version (29211)
Channel: stable
Build: 4271b9e

Windows 10 version 1809

I had the same problem. For those wanting a workaround until an update is available, you can remove the Docker entry from the registry:

1 - Open Regedit
2 - Check “HKCU\Software\Microsoft\Windows\CurrentVersion\Run” and “HKLM\Software\Microsoft\Windows\CurrentVersion\Run” (mine was under HKCU).
3 - Remove the entry with “Docker for Windows”.
4 - Restart the computer.

For me this fixed the problem and Docker is no longer starting on Windows startup.


This fixed for me! Thanks for the workaround!

Uninstalling Docker Desktop for winders… not messing with the registry.

1 Like

Mine was also under HKCU\Software\Microsoft\Windows\CurrentVersion\Run and removing the Docker for Windows entry did the trick: thank you!


Uninstalled the docker for now.

1 Like

Same problem on a fresh installation of Win10 1809.

The registry hack suggested by @qmennens solved the issue.

To remove via (elevated) PowerShell

Remove-ItemProperty 'HKCU:\Software\Microsoft\Windows\CurrentVersion\Run' -Name 'Docker for Windows'

Yep same here
Win10 Pro 1809
Version (29211)
Channel: stable
Build: 4271b9e

Why don’t you use the task-manager to disable the autorun?

Right-click on the start-bar > task-manager > click on more details at the bottom > goto to Autostart tab > select Docker for Windows in the list and click on Disable button.

This is not really shorter but less scary in my eyes :wink:


Why don’t you use the task-manager to disable the autorun?

This would work, if docker is started via windows autostart, which it isn’t for me. So that i can’t deselect it in the task-manager.

Btw, even with version deselecting on boot option does not work.

That works fine! Tanks!

For my system (Win 10 Pro 1809, Docker, the registry location was at:


And two other HKEY_USERS\[xxLONG STRING HERExx]\Software\Microsoft\Windows\CurrentVersion\Run

I had to use the Find menu option to search for Docker for Windows keys by name to get rid of it from startup.


Removing the second key worked for me, thank you!

I still wonder why the general behaviour ist not fixed by the docker team.

Ooh, I love messing with the registry!

1 Like

This issue seems to be due to registry entries left over by previous versions.
At one point in time, the auto-start was handled by the following registry value
HKCU:\Software\Microsoft\Windows\CurrentVersion\Run\Docker for Windows

A little later they renamed this value to “Docker Desktop”, but the “Docker for Windows” did not get deleted or taken over when upgrading.

If you toggle the setting “Start Docker Desktop when you log in” on and off, you will see that “Docker Desktop” appears and disappears from HKCU:\Software\Microsoft\Windows\CurrentVersion\Run, which shows that the current implementation works fine.

After deleting the obsolete “Docker for Windows” value from your registry, the “Start Docker Desktop when you log in” setting shall be honored.


Thanks @reureu, removing the extra entry in my registry helped to beat Docker into submission, now it’s starting only when it’s told to.
Just out of curiosity I uninstalled Docker, and verified that there’s no “Docker for Windows” entry listed under Run. Then I installed Docker, and both Docker Desktop and Docker for Windows showed up. Deleting the extra one fixed the problem again. It looks like Docker installer adds the extra entry every time Docker is installed, but the settings panel changes only one of the two entries.

1 Like

Well spotted @dusandz!
It’s something the team in charge of the installation package for Windows will need to fix.

Thansk @reureu and @dusandz. I can confirm the issue still exists on a clean PC with no previous docker versions installed I am seeing both registry entries.

Kind of disappointing this is still an issue 5 months after this thread was opened…

Is there an ‘official’ bug report?

Windows 10 Enterprise
Version 10.0.17134 Build 17134