Docker Community Forums

Share and learn in the Docker community.

Docker died after power outage, can't get it reinstalled

A power outage happened and my Raspberry Pi went down, obviously not in a managed way. Following this, I booted the system again and now, for some reason, the Docker daemon won’t start.

Running Linux 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux (Raspbian).

I tried :

  • Rebooting. Still not working.

  • apt-get update & apt-get upgrade. Nope.

  • Removing things like /var/run/docker.sock and rebooting. Still not working.

  • Official uninstall instruction step 1 from the Docker documentation, rebooting, then running the convenience script from the Docker site to reinstall. Still not working, exits with an error.

  • Deleting /var/lib/docker (sadness!) and then the aforementioned steps. Still not working, exits with an error. Tried to run some random ‘do this to save things’ commands from random web sites, because I really don’t know what I am doing here. Nope. No change.

So, because the issue encountered by the convenience script seemed to be not being able to install docker-ce, I tried to run sudo apt install docker-ce separately. Here is what eventually appeared on the screen :

Setting up docker-ce (5:19.03.12~3-0~raspbian-buster) ...

Job for docker.service failed because the control process exited with error code.

See "systemctl status docker.service" and "journalctl -xe" for details.

invoke-rc.d: initscript docker, action "start" failed.

● docker.service - Docker Application Container Engine

Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)

Active: activating (auto-restart) (Result: exit-code) since Sat 2020-06-27 15:28:51 +07; 57ms ago


Process: 3011 ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock **(code=exited, status=1/FAILURE)**

Main PID: 3011 (code=exited, status=1/FAILURE)

**dpkg:** error processing package docker-ce (--configure):

installed docker-ce package post-installation script subprocess returned error exit status 1

Setting up libltdl7:armhf (2.4.6-9) ...

Setting up git-man (1:2.20.1-2+deb10u3) ...

Setting up cgroupfs-mount (1.4) ...

Setting up git (1:2.20.1-2+deb10u3) ...

Processing triggers for systemd (241-7~deb10u4+rpi1) ...

Processing triggers for man-db (2.8.5-2) ...

Processing triggers for libc-bin (2.28-10+rpi1) ...

Errors were encountered while processing:


E: Sub-process /usr/bin/dpkg returned an error code (1)

I don’t have the skills to fix this and at this point am wondering if I need to reinstall the entire system. But surely on a platform like Linux this isn’t required?

Hopefully somebody can help guide me through this situation?

Maybe the SD card is corrupted. Try with a new one. Yes, this means you have to reinstall the system.

Sorry, forgot to mention … the system runs off an SSD.

I have the same Issue. I have been always using a Home-assistant on a linux and now, when I wanted to move to a dedicated I get the same error. My PI 3 B event don’t want to install. Tried HassOS Release 1 build 9 (Stable) and also Development 2 build 1. Nothing helps. I’ getting connection refused on CLI and on http://rpi_ip:8123. Can’t even get logs