Docker Community Forums

Share and learn in the Docker community.

Docker [error response]: Failed to choose a UCP node. UCP node does not exist

My docker server version is 1.13.1-cs3

I have successfully installed UCP on three nodes (1 Manager, and 2 worker nodes). UCP is working without a glitch. But whenever I have tried to install DTR, it is not installing. Instead, I am getting this error:

INFO[0037] Validating UCP cert                          
INFO[0037] Connecting to UCP                            
INFO[0038] UCP cert validation successful               
INFO[0038] The UCP cluster contains the following nodes: docker1vb, docker2vb, docker3vb 
FATA[0039] failed to choose ucp node: The UCP node 192.168.10.24 does not exist. Please pick one from the list above. 

The docker run command is as follows:

docker run -it --rm docker/dtr install --ucp-node 192.168.10.24 --ucp-insecure-tls

dtr-external-url -> https://192.168.10.24:443
ucp-url -> https://192.168.10.22:443
ucp username: admin
ucp password: xxxxxxxx

Where am i making a mistake? I tried to google this, but the efforts ended being a waste. Help Needed!

Sorry about the delay in getting back to you. The problem is the node name is set as an IP address instead of what UCP thinks is the node name. In this case you can go to your UCP console and look up the node name and should be able to use that with the --ucp-node flag.