Docker images are not running on my macbook M2

Docker Desktop is installed on my MacBook Air M2 machine. I can retrieve any kind of image, but I can’t run them; They end immediately and without a log or error.

I tried to enable Use Rosetta for x86/amd64 emulation on Apple Silicon, but I got the same result.

If there is no error message, then there is probably nothing to run. If you share how you run the containers, we my be able to tell you what is wrong with the command.

Please, format the shared commands according to the following guide: How to format your forum posts and use code blocks like

docker run ...

If you build your own image, then the content of the Dockerfile could help too.

Running. into same issue try installing colima

brew install colima 
colima start
dockekr run ...

Out of the box docker won’t support other than arm64 architecture on mac with m1/m2 chipset, it seems.
Colima shoud ad a qemu based virtualization layer ( or so I’m told ) making it possible to run docehr containers with a different architecture.

Did you check the full doc?

Did you use brew install docker?

Not sure if the MacOS x86/x64 emulator (“Rosetta 2”) is needed for this:

create VM with Rosetta 2 emulation. Requires v0.5.3 and MacOS >= 13 (Ventura)

colima start --arch aarch64 --vm-type=vz --vz-rosetta