Docker Community Forums

Share and learn in the Docker community.

Docker install on Linux Mint 19 - Codename: Tara - PackageBase: Ubuntu Bionic


I tried to install docker on Linux
Details as below -
Mint version 19,
Code name : Tara,
PackageBase : Ubuntu Bionic
Cinnamon (64-bit)

Referenced link:


1. sudo apt-get remove docker docker-engine

2. sudo apt-get update

3. sudo apt-get install apt-transport-https ca-certificates curl software-properties-common

4. curl -fsSL | sudo apt-key add -

5. sudo apt-key fingerprint 0EBFCD88

6. sudo add-apt-repository "deb [arch=amd64] \
$(lsb_release -cs) \

7. sudo apt-get update

8. sudo apt-get install docker-ce

For step 6 I checked lsb_release -cs

xxxxxxxxx:~$ lsb_release -cs

I see issue at step 7.

xxxxxxxxxxx:~$ sudo apt-get update
Ign:1 tara InRelease
Hit:2 tara Release                                                                                                                        
Hit:3 bionic InRelease                                                                                                             
Hit:4 bionic-updates InRelease                                                                                                     
Ign:5 stable InRelease                                                                                                            
Hit:7 bionic-backports InRelease                                                                                                   
Hit:8 bionic InRelease                                                                                                              
Get:9 bionic-security InRelease [83.2 kB]                    
Hit:10 stable Release                                                
Ign:11 tara InRelease                                             
Err:13 tara Release                         
  404  Not Found [IP: 2600:9000:2045:3c00:3:db06:4200:93a1 443]
Reading package lists... Done                      
E: The repository ' tara Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

As an effect for step 8 I see below error.

xxxxxxxx:~$ sudo apt-get install docker-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package docker-ce is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'docker-ce' has no installation candidate

Looks like there is some issue with linux mint Tara or Ubuntu Bionic with Docker.

Can someone tell me how to resolve the issue and install docker?

The Docker repository at doesn’t know about Linux Mint’s code name tara . Use Ubuntu’s codename, bionic .

step 6 above should be this instead:

sudo add-apt-repository "deb [arch=amd64] bionic stable"

If you continue to see warnings with apt-get update because you still have the old (incorrect) source listed. To fix these, you can delete the corresponding file (the one that says tara from /etc/apt/sources.list.d/ , or use another GUI or command line tool to do this for you.

Just a note but the URL is: Prolly a cut and paste error. The ‘m’ was missing from ‘com’

Thanks for the tip though, helped me out. Cheers!

add-apt-repository causing error Malformed input, repository not added.
Instead i added it in the /etc/apt/sources.list.d/additional-repositories.list

Thanks :+1:

1 Like

Same issue using Linux Mint 19.2. Which version do you use? As I see from, all is fine if it’s 19 not 19.1 or 19.2

solved this issue:
Malformed input, repository not added.

after downgrading to Linux Mint 19 (not 19.1 or 19.2). But also you can add a new line to additional repositories file manually.