Docker Community Forums

Share and learn in the Docker community.

Docker installation failed

Sorry, I don’t know if that’s the right category? I’m new to this community and to docker ^^

I want to install docker, but the installation fails because of iptables.
The error message:

dockerd[4056]: failed to start daemon: Error initializing network controller: Error creating default “bridge” network: Failed to program NAT chain: Failed to inject DOCKER in PREROUTING chain: iptables failed: iptables --wait -t nat -A PREROUTING -m addrtype --dst-type LOCAL -j DOCKER: iptables: No chain/target/match by that name.
dockerd[4056]: (exit status 1)
systemd[1]: docker.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: Failed to start Docker Application Container Engine.
systemd[1]: docker.service: Unit entered failed state.
systemd[1]: docker.service: Failed with result ‘exit-code’.

I’ve already tried several classic solutions (e.g. flushing iptables). But without any result.

Important: The installation already fails. So docker is not installed.

Issue type: Bug?
OS: Debian 9.12
App-Version: should be the newest one
Steps to reproduce:
idk, I just tried to install it with

apt-get install docker-ce docker-ce-cli containerd.io