Docker Community Forums

Share and learn in the Docker community.

Docker isn't starting up on Linux box

docker

(Vijayramachandran) #1

Hi there,

We are not able to start docker, and it gives this error, tried all the possibilities, not getting what is the issue on here?

OS : RHEL 7.3
Application : Cloudera Workbench

Blockquote
$ sudo service docker status -l
Redirecting to /bin/systemctl status -l docker.service
â docker.service - docker
Loaded: loaded (/etc/systemd/system/docker.service; disabled; vendor preset: disabled)
Active: activating (auto-restart) (Result: exit-code) since Wed 2017-09-06 13:33:14 CEST; 5s ago
Docs: https://docs.docker.com
Process: 6602 ExecStopPost=/usr/sbin/ifconfig docker0 down (code=exited, status=255)
Process: 6576 ExecStart=/usr/bin/docker daemon --log-driver=journald -s devicemapper --storage-opt dm.basesize=100G --storage-opt dm.thinpooldev=/dev/mapper/docker-thinpool --storage-opt dm.use_deferred_removal=true --iptables=false (code=exited, status=1/FAILURE)
Main PID: 6576 (code=exited, status=1/FAILURE)

Sep 06 13:33:14 systemd[1]: Failed to start docker.
Sep 06 13:33:14 systemd[1]: Unit docker.service entered failed state.
Sep 06 13:33:14 systemd[1]: docker.service failed.

Please help on this.


(Werner Dijkerman) #2

This does not provide much information, does: journalctl -u docker.service show you something?


(Vijayramachandran) #3

Thank you for your response, but I have done so much of research on this, and found some bits and pieces of info to fix this.

The issue was that, the docker was expecting some of the services like rpc to enable it up, but it couldn’t able to do. I tried to manually enable that command, but it didn’t work. - this is a combination of CDSW and docker, not only does this.

Then I tried to disable it manually and then let the CDSW script to bring it up, it worked after that.