Docker Community Forums

Share and learn in the Docker community.

Docker login: Dial tcp: lookup read udp i/o timeout

Expected behavior

docker login should succeed

Actual behavior

docker login fails with the following message:
Error response from daemon: Get dial tcp: lookup on read udp> i/o timeout


The problem has persisted across several tests:

  • restarting Docker for Mac
  • restarting my host machine
  • deleting and re-adding my Wi-Fi network

It has occurred trying to docker login to both Docker Hub and AWS Elastic Container Registry.

It may be an issue with version: v1.11.1-beta14.5.m which I just installed today. I hadn’t tried to docker login in several days prior so I’m not sure whether the issue started with this beta version.

I can say that I’ve successfully used docker login, docker pull, and docker push many times in the past using docker-machine with VirtualBox. Just unsure about previous behavior with the native beta.

$ pinata diagnose -u
OS X: version 10.11.5 (build: 15F34) version: v1.11.1-beta14.5.m
Running diagnostic tests:
[OK]      docker-cli
[OK]      Moby booted
[OK]      driver.amd64-linux
[OK]      vmnetd
[OK]      osxfs
[OK]      db
[OK]      slirp
[OK]      menubar
[OK]      environment
[OK]      Docker
[OK]      VT-x
Docker logs are being collected into /tmp/20160607-110936.tar.gz
Most specific failure is: No error was detected
Your unique id is: 6DC4D23A-C120-4BAA-A11F-00EE029D7766
Please quote this in all correspondence.

Steps to reproduce the behavior

$ docker login
# enter username and password
Error response from daemon: Get dial tcp: lookup on read udp> i/o timeout


$ aws ecr get-login
docker login -u AWS -p <long secret token> -e none https://<account id>
# run the command printed above
Error response from daemon: Get https://<account id> dial tcp: lookup <account id> on read udp> i/o timeout

I was able to fix this by using the “Reset to factory defaults” function within Settings.

That meant deleting my local images in Docker for Mac. Naturally I couldn’t push them beforehand since docker login did not work. Fortunately I was able to back them up using docker save from Docker for Mac and then docker load from my Docker Toolbox installation.

This helped:

1 Like

Having the same problem in windows docker
Docker version 1.12.0-rc2, build 906eacd, experimental

Error response from daemon: Get dial tcp: lookup on read udp> i/o timeout

1 Like

Same issue here as @dmikov, but with a private registry. Any advice?


+1 having this issue as well, with Docker for Mac 1.12.0-rc2. I have reset to factory default as well, still no dice.

1 Like

+1 Same issue with private registry


works for me!


Same here with Docker for Mac Version 1.12.0-rc2-beta16 (build: 9493). Reset does not help.

1 Like

Having a similar issue also on Version 1.12.0-rc2-beta16 (build: 9493)

$ docker pull alpine
Using default tag: latest
Error response from daemon: Get Get dial tcp: lookup on no such host

1 Like

There are at least two threads (including this one):

I can login to AWS ECR and pull images, but not the docker registry.

I have similar issue with Docker for mac. My diagnostic ID: E439CFAC-9936-4585-B8EB-7AB6E9CEA652

Previously I had working docker-machine with virtualbox. But I uninstalled everything(deleting every image/container) and removed any bashrc and /etc/hosts/ changes.

I have a wifi connection, if that info helps.

Version Version 1.12.0-rc2-beta16 (build: 9493)

I believe I’ve tracked this down to truncated DNS responses from upstream DNS causing Docker’s embedded DNS server to fail since it seem to be listening via TCP:


Same issue (I use internal bind DNS). Is there a place to open a bug for this, if not already?

$ dig | head -n2
;; Truncated, retrying in TCP mode.

$ dig @ | head -n2
; <<>> DiG 9.8.3-P1 <<>> @

Diagnostic ID: 08466D37-2F75-4FBA-9D4D-6DF461FA8960

1 Like

FYI I just restarted the bind daemon and oddly it now returns a DNS response small enough not to be truncated into TCP mode, which fixed docker as well.

+1 on this issue.
I restarted which didn’t clear the issue - oddly I disabled my wireless and forced my wired network connection, restarted and the log in went through and I was able to push my image to Docker Hub.

Here’s the issue on Github – it’s been identified and possibly fixed but not released.

1 Like

what solved it for me is adding an A record for in my hosts file, e.g.:

then it started working.

1 Like

Thanks, it works well on my Docker on Windows Server 2016.

The problem solved by reset the docker settings to factory defaults. Thanks @skarger

What is the IP - That of the Registry?

I tried all of the above and nothing worked, running win 10
but i found it!

for my work i need a socks client (opentext socks) to connect to our virtual environment
this application interfered with the network connections docker tried to establish, after disabling the socks client all went well !

regards JW