Docker Community Forums

Share and learn in the Docker community.

Docker PowerCLI Script Error: standard_init_linux.go:178: exec user process caused "exec format error"

Hi, I am trying to automate a script from a Mac that will run docker and inmediately run powercli (Vmware) to restore VMs. If I run it through the docker itself, works great but when I try to run the script, its throw the following error:

Command: docker run --rm -it -v /Users/Dev/Desktop/scripts:/tmp/scripts vmware/powerclicore /tmp/scripts/simplescript.ps1

Error: standard_init_linux.go:178: exec user process caused “exec format error”

Docker Info:

*Containers: 0
Running: 0
Paused: 0
Stopped: 0
Images: 1
Server Version: 1.13.0
Storage Driver: overlay2
Backing Filesystem: extfs
Supports d_type: true
Native Overlay Diff: true
Logging Driver: json-file
Cgroup Driver: cgroupfs
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 03e5862ec0d8d3b3f750e19fca3ee367e13c090e
runc version: 2f7393a47307a16f8cee44a37b262e8b81021e3e
init version: 949e6fa
Security Options:
seccomp
Profile: default
Kernel Version: 4.9.4-moby
Operating System: Alpine Linux v3.5
OSType: linux
Architecture: x86_64
CPUs: 2
Total Memory: 1.952 GiB
Name: moby
ID: 7QYQ:ZP5I:46CY:FYON:3QB2:ITPS:KI7T:U2T7:22JG:5KBX:NA2U:BARV
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): true
File Descriptors: 17
Goroutines: 28
System Time: 2017-02-03T20:01:20.347201104Z
EventsListeners: 1
No Proxy: .local, 169.254/16
Registry: https://index.docker.io/v1/
Experimental: true
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false

Now, I tried adding the bang bash before and although it mounts the drive and script, it does not run it.
I am kind of new with scripting on docker so apologize any obvious reasons. Any help is greatly appreciated!