Docker Community Forums

Share and learn in the Docker community.

Docker-proxy resetting tcp connections [solved]

docker

(Paul Tötterman) #1

Hi,

I’m having trouble with graylog in docker, described here

What might be the reason for the connection getting an immediate RST via docker-proxy, but not when connecting directly?


(Jeff Anderson) #2

I’d be curious to know if you see the problem go away by removing the userspace proxy or not.

If you launch docker daemon with the --userland-proxy=false option, it should use pure iptables instead of docker-proxy.


(Paul Tötterman) #3

I only now got a chance to test this. Seems like it must be a bug in docker 1.6.2 that I used before. Docker 1.10 does not seem to have the same behaviour.