Docker Push Error : FATA[0001] Respository does not exist

having the same issue:-(

FATA[0000] Repository does not exist: rkarakaya/test

Client version: 1.6.0
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 4749651
OS/Arch (client): linux/amd64
Server version: 1.6.0
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 4749651
OS/Arch (server): linux/amd64

Hi,

People with docker version 1.5.0-dev - you are either using a development version built of master, or a modified docker.

If the former, please update to a stable/released version.
If the latter, then please turn to your distro (or whoever ships that modified docker).

Otherwise, let’s try to sort it out:

@rkarakaya I don’t see anything here: https://registry.hub.docker.com/u/rkarakaya/test/

Have you pushed something yet?

I have the same issue. I’m correctly logged on docker from the CLI. When trying to push to acastaner/website (https://registry.hub.docker.com/u/acastaner/website/) but docker tells me it doesn’t exist:

arnaud@ks37546:~/dev$ docker push acastaner/website
The push refers to a repository [acastaner/website] (len: 0)
FATA[0000] Repository does not exist: acastaner/website

I run docker 1.6 on Ubuntu 14.04:

arnaud@ks32346:~/dev$ docker version
Client version: 1.6.0
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 4749651
OS/Arch (client): linux/amd64
Server version: 1.6.0
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 4749651
OS/Arch (server): linux/amd64

I think I found the reason - minutes after I posted, of course :smile:
The name of the image didn’t match the repository - once I changed the name of the image, I managed to push. Maybe the error should be more clear?

1 Like

I ran into same issue but updated the repo as per the post and that fixed it. I did rebuild my image to match the repo name. So two things needed to happen to fix this.

Thanks
Rj

I’m having the same issue on Fedora21, and can’t seem to resolve it no matter what I do. There has to be something bigger going on here… Here is the message in my docker debug log:

sudo docker version (from Fedora 21 guest inside Windows 7 Host)

Client version: 1.6.0
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 3eac457/1.6.0
OS/Arch (client): linux/amd64
Server version: 1.6.0
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 3eac457/1.6.0
OS/Arch (server): linux/amd64

sudo docker push - beetee2/personal-meteor

ERRO[2015] Handler for POST /images/{name:.}/push returned error: Error: Status 403 trying to push repository beetee2/meteor-personal to official registry: needs to be forced
ERRO[2015] HTTP Error: statusCode=403 Error: Status 403 trying to push repository beetee2/meteor-personal to official registry: needs to be forced
DEBU[2017] Calling POST /images/{name:.
}/push
INFO[2017] POST /v1.18/images/beetee2/meteor-personal/push?force=1&tag=
INFO[2017] +job push(beetee2/meteor-personal)
INFO[2017] +job resolve_repository(beetee2/meteor-personal)
INFO[2017] -job resolve_repository(beetee2/meteor-personal) = OK (0)
INFO[2017] Push of beetee2/meteor-personal to official registry has been forced
DEBU[2017] pinging registry endpoint https:/ /index.docker.io/v1/
DEBU[2017] attempting v1 ping for registry endpoint https:/ /index.docker.io/v1/
Repository does not exist: docker.io/beetee2/meteor-personal
INFO[2017] -job push(beetee2/meteor-personal) = ERR (1)

sudo docker push -f beetee2/personal-meteor

DEBU[1964] Calling POST /images/{name:.*}/push
INFO[1964] POST /v1.18/images/beetee2/meteor-personal/push?force=1&tag=
INFO[1964] +job push(beetee2/meteor-personal)
INFO[1964] +job resolve_repository(beetee2/meteor-personal)
INFO[1964] -job resolve_repository(beetee2/meteor-personal) = OK (0)
INFO[1964] Push of beetee2/meteor-personal to official registry has been forced
DEBU[1964] pinging registry endpoint https:/ /index.docker.io/v1/
DEBU[1964] attempting v1 ping for registry endpoint https:/ /index.docker.io/v1/
Repository does not exist: docker.io/beetee2/meteor-personal
INFO[1964] -job push(beetee2/meteor-personal) = ERR (1)

I’ve updated my fedora installation which included my linux headers. I’ve uninstalled and re-installed docker. I’ve tried keeping beetee2/meteor-personal ADDED to my DockerHub, and tried REMOVING it from my DockerHub, then pushing. I’ve tried sudo rm -rf /var/lib/docker/devicemapper. I’ve tried running the docker daemon with --dns specified (I use OpenDNS). I’ve tried disabling DNS.

None of it has worked obviously.

I’d greatly appreciate any tips in fixing this issue.

Yes I manually put the space in between http:/ / because “new users can’t post more than 2 links in a post”.

I sidestepped this issue by creating an ubuntu vm on Digital Ocean, ssh-ing in and cloning my git repo, vim-ing the files that need changed, installing docker, and pushing the image to DockerHub from that machine. So I’m not sure if it was a firewall issue or exactly what the problem was.

I’m seeing this same issue as well, though I’m using overlay instead of device-mapper.

Same issue here with Fedora 21. I too tried first without a repo in dockerhub, then after creating an empty repo in dockerhub, then deleting it and trying again. All with the same errors. I can pull things from docker.io/fedora/* no problem so I don’t think this is a DNS issue.

$ sudo docker images
REPOSITORY TAG IMAGE ID CREATED VIRTUAL SIZE
thesteve0/openshift-qpid latest 4ff0b3679c09 2 minutes ago 607.1 MB

$ sudo docker push thesteve0/openshift-qpid:latest
Do you really want to push to public registry? [Y/n]: Y
The push refers to a repository [docker.io/thesteve0/openshift-qpid] (len: 1)
FATA[0001] Repository does not exist: docker.io/thesteve0/openshift-qpid

$ sudo docker -v
Docker version 1.6.0, build 3eac457/1.6.0

Confirming that this DOES work on Fedora 20 with docker 15. Also a co-worker has confirmed this works with Docker 16 on Ubuntu. So my guess is that this is a fedora issue. I am going to move it over to them.

Work around on Fedora 21 with docker 16 is to use the following syntax:

sudo docker push docker.io/thesteve0/openshift-qpid:latest

Looks like there’s an updated package in the f21 updates-testing repo that resolves this issue.

I did a yum update today and was upgrader to 1.6. Same problem as everyone else.

How do I get the fix you mentioned, Jason?

Thansk

yum install --enablerepo=updates-testing docker-io

The package currently out there is docker-io-1.6.0-4.git350a636.fc21.x86_64

Lovely. Thanks, Jason.

Installed it, restarted docker daemon and still get the same error.

Could you paste the output of “docker version” and “docker info”?

Client version: 1.6.0
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 350a636/1.6.0
OS/Arch (client): linux/amd64
Server version: 1.6.0
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 350a636/1.6.0
OS/Arch (server): linux/amd64

Containers: 97
Images: 182
Storage Driver: devicemapper
Pool Name: docker-253:1-918119-pool
Pool Blocksize: 65.54 kB
Backing Filesystem: extfs
Data file: /dev/loop0
Metadata file: /dev/loop1
Data Space Used: 32.42 GB
Data Space Total: 107.4 GB
Data Space Available: 9.036 GB
Metadata Space Used: 34.31 MB
Metadata Space Total: 2.147 GB
Metadata Space Available: 2.113 GB
Udev Sync Supported: true
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Library Version: 1.02.93 (2015-01-30)
Execution Driver: native-0.2
Kernel Version: 3.19.5-200.fc21.x86_64
Operating System: Fedora 21 (Twenty One)
CPUs: 4
Total Memory: 3.658 GiB
Name: ageorge
ID: CMEK:VPWF:3MDB:GWWS:PPAQ:OFRJ:UDD5:UFLY:QZPN:EXUP:Z5S2:CTTX
Username: ageorge
Registry: [https://index.docker.io/v1/]

sudo docker push apsd/wso2-am

Do you really want to push to public registry? [Y/n]: Y
The push refers to a repository [docker.io/apsd/wso2-am] (len: 0)
FATA[0002] Repository does not exist: docker.io/apsd/wso2-am

Hmmm… it worked fine for me, though I’m using overlayfs instead of devicemapper. Not that I would expect that to make a difference.

Updated with the updates-testing package:

docker push ${login_name}/${image_name} fails
docker push docker.io/${login_name}/${image_name} fails

docker tag ${image_id} docker.io/${login_name}/${image_name} and then docker push docker.io/${login_name}/${image_name} is OK

└> docker version
Client version: 1.6.0
Client API version: 1.18
Go version (client): go1.4.2
Git commit (client): 350a636/1.6.0
OS/Arch (client): linux/amd64
Server version: 1.6.0
Server API version: 1.18
Go version (server): go1.4.2
Git commit (server): 350a636/1.6.0
OS/Arch (server): linux/amd64

└> docker info
Containers: 1
Images: 1017
Storage Driver: devicemapper
 Pool Name: docker-253:3-25304450-pool
 Pool Blocksize: 65.54 kB
 Backing Filesystem: extfs
 Data file: /dev/loop0
 Metadata file: /dev/loop1
 Data Space Used: 33.4 GB
 Data Space Total: 107.4 GB
 Data Space Available: 73.97 GB
 Metadata Space Used: 44.45 MB
 Metadata Space Total: 2.147 GB
 Metadata Space Available: 2.103 GB
 Udev Sync Supported: true
 Data loop file: /home/docker/devicemapper/devicemapper/data
 Metadata loop file: /home/docker/devicemapper/devicemapper/metadata
 Library Version: 1.02.93 (2015-01-30)
Execution Driver: native-0.2
Kernel Version: 3.19.5-200.fc21.x86_64
Operating System: Fedora 21 (Twenty One)
CPUs: 4
Total Memory: 15.62 GiB
Name: fedolooz.kalaari.net
ID: TMPI:T5I4:XRWA:UXE2:IQJK:RUWS:HTIZ:4MIR:TNUX:ZULS:G4R5:MZ6J
Username: looztra
Registry: [https://index.docker.io/v1/]