Docker Community Forums

Share and learn in the Docker community.

Docker push is failing


(Deba) #1

I have setup DTR in my own test env, not able to push after succcesful login

[root@ululin033 certs.d]# docker push host.auiag.corp/debajyoti/db:latest
The push refers to a repository [host.auiag.corp/debajyoti/db]
5f70bf18a086: Waiting
a76baa901397: Waiting
7f4483f420b9: Waiting
bfe91c2e34ff: Waiting
7fe413a20278: Waiting
e476919e4262: Waiting
4255943f87f4: Waiting
cef2101c0d59: Waiting
1139f2abfa6e: Waiting
eb1cd5396a1e: Waiting
3bda5ea7bb71: Waiting
5ab14a6ae81b: Waiting
1ae3c4641b70: Waiting
e1453d77e839: Waiting
e93a93508481: Waiting
0c03669d5318: Waiting
1d0337ad8e00: Waiting
45d97e0c31d3: Waiting
cb78f45425a1: Waiting
22db29a617c2: Waiting
4a43e046ff41: Waiting
c013692b99c0: Waiting
947dfc4bcb27: Waiting
556d9c8f4742: Waiting
unauthorized: authentication required

Docker version 1.10.0, build 590d5108


(Kostasmistos) #2

Have the same issue expect my output says “preparing”

root@xxxxx:/home/ubuntu# docker push privateregistry.com/myname/hello-mine
The push refers to a repository [privateregistry.com/myname/hello-mine]
5f70bf18a086: Preparing
b652ec3a27e7: Preparing
unauthorized: authentication required

Docker version 1.10.1, build 9e83765


(Siddharth67) #3

From where are you trying to Push the image? Some people have the same issue while trying to push from Docker Quickstart Terminal.
Try doing it from boot2docker.
In your Docker Quickstart Terminal,
docker-machine ssh default
This cmd opens up the boot2docker cli inside Docker.
Login again and push the image, it should work.


(Kostasmistos) #4

I have an openstack infrastructure with 3 nodes created a swarm cluster.
From the swarm manager node i make
docker login "myprivateregistry"
login is successful

and then make the docker push which gives me
the results presented previously.


(Deba) #5

I got a centos box which is running the trial DTR. The images are are in the same box.


(Polarn) #6

Hello,

I have the same symptoms, did anyone get it to work? I’ve tried to use managed login and LDAP, both gives the same error. Can’t use the admin user either, get the same “unauthorized: authentication required” when pushing - but docker login works.


(Deba) #7

Yes , that’s the issue .

Now I stopped testing DTR .


(Yasir484) #8

Was anybody able to fix it? I have the same issue:

[root@ ~]$ docker push test-serverdemo.net/admin/rhel72base:test
The push refers to a repository [test-server.demo.net/admin/rhel72base]
46ebb98ce123: Preparing
unauthorized: authentication required

I am using Docker version 1.10.2-cs1, build 8e23741


(Yasir484) #9

I was able to push the images using a non-admin account. For some wired reason it does not work for admin account.


(Shibinarayan) #10

Anybody got the fix?
I’m also facing the same issue.

e38cbad13768: Waiting
44267ec3aa94: Waiting
bd750002938c: Waiting
917c0fc99b35: Waiting
unauthorized: authentication required


(Miwalker) #11

I get this error on a push if the repository I’m referencing hasn’t been created yet in DTR. If repo doesn’t exist I can login fine from client, but push give me the unauthorized error. Once I create the repository in DTR and give the user access, I can then push successfully with admin or non-admin id that has access to repository.


(Motmoore) #12

You need to manually create the repository in the GUI FIRST! The unauthorized error is deceiving. In the example of docker push test-serverdemo.net/admin/rhel72base:test YOU need to create the admin/rhel72base repository in the gui.


(Darryl Rubarth) #13

I’m running docker version 1.10.3 and was having the exact same “unauthorized: authentication required” error. This started happening sometime over the past week, maybe two at most. I had previously pushed the image successfully. To fix this issue I logged into hub.docker.com and through the GUI I removed the existing image and then ran the docker push again – and it worked!


(Darryl Rubarth) #14

The bad news is that I apparently have to delete the image via the GUI each time before I want to push a new one. Is there a way to do this from the command line?


(Augustin Riedinger) #15

You solution did not work for me @drubarth. Any other fix to suggest? I also tried:

without success …