Docker Run Error with --storage-opt and Overlay2 on XFS with pquota


I don’t know why I am getting this error.

According to the documentation at docker run | Docker Docs, --storage-opt should work with overlay2, and the backing filesystem is XFS mounted with pquota. I’ve been trying for a while, but I keep encountering this error. If anyone knows a solution, your help would be greatly appreciated.

On what operating system? Which docker version? How did you install it from which repo? Please share the output of the following commands:

docker info
docker version
snap list docker

When you share the output, please, share each output in separate code blocks following this guide: How to format your forum posts

Hi @rimelek
Thanks for your reply,

I am on ubuntu 22.04 and Installed docker officialy from here Install Docker Engine on Ubuntu | Docker Docs

Here are your required output,

ubuntu@ip-172-31-15-152:~$ docker info
 Version:    24.0.5
 Context:    default
 Debug Mode: false

 Containers: 1
  Running: 1
  Paused: 0
  Stopped: 0
 Images: 2
 Server Version: 24.0.5
 Storage Driver: overlay2
  Backing Filesystem: extfs
  Supports d_type: true
  Using metacopy: false
  Native Overlay Diff: true
  userxattr: false
 Logging Driver: json-file
 Cgroup Driver: systemd
 Cgroup Version: 2
  Volume: local
  Network: bridge host ipvlan macvlan null overlay
  Log: awslogs fluentd gcplogs gelf journald json-file local logentries splunk syslog
 Swarm: inactive
 Runtimes: runc io.containerd.runc.v2
 Default Runtime: runc
 Init Binary: docker-init
 containerd version:
 runc version:
 init version:
 Security Options:
   Profile: builtin
 Kernel Version: 6.2.0-1012-aws
 Operating System: Ubuntu 22.04.3 LTS
 OSType: linux
 Architecture: x86_64
 CPUs: 4
 Total Memory: 15.32GiB
 Name: ip-172-31-15-152
 ID: 6b042b0f-e260-4b24-a9d3-1ed982cc6c53
 Docker Root Dir: /var/lib/docker
 Debug Mode: false
 Experimental: false
 Insecure Registries:
 Live Restore Enabled: false
ubuntu@ip-172-31-15-152:~$ docker version
 Version:           24.0.5
 API version:       1.43
 Go version:        go1.20.3
 Git commit:        24.0.5-0ubuntu1~22.04.1
 Built:             Mon Aug 21 19:50:14 2023
 OS/Arch:           linux/amd64
 Context:           default

  Version:          24.0.5
  API version:      1.43 (minimum version 1.12)
  Go version:       go1.20.3
  Git commit:       24.0.5-0ubuntu1~22.04.1
  Built:            Mon Aug 21 19:50:14 2023
  OS/Arch:          linux/amd64
  Experimental:     false
  Version:          1.7.2
  Version:          1.1.7-0ubuntu1~22.04.1
  Version:          0.19.0
ubuntu@ip-172-31-15-152:~$ snap list docker
error: no matching snaps installed

Are you sure this dir

is on a xfs file system?

The backing file system look like ext4.

If the docker root dir would be on xfs, it should look like this:

  Backing Filesystem: xfs

Hi @meyay

I have tried with both file backing system (extfs and xfs) but getting same issue

you can see in the SS

Also tried this Storage quota per container - overlay2 backed by xfs but did’nt work!

Did you upgrade the kernel on aws or 6.2 was the default? Ubuntu 22.04 has the kernel v5.15 by default. I know there is a v6.2 HWE, but I never tried it with that kernel. Do you have any way to try with a v5.15?

It’s default 6.2, have you tried this its working for you ??

You might want to raise an issue in the Moby Github project: Issues · moby/moby · GitHub

You should add the output for docker info, docker version and the relevant /etc/fstaboder/etc/mtabthat show that the pgquote` option is actually used + the error your shared in your first post (but please share it as text instead of a screenshot of text)

Good point, I simply ignored the fact that we are talking about storage opts. I think I have tried it long time ago and worked, but back then I had an older Ubuntu distribution. Maybe Ubuntu 20.04 or even 18.04.

ohh, btw i have tried with kernel v5.15 but did’nt work

yeah…Docker Run Error with –storage-opt and Overlay2 on XFS with pquota · Issue #46823 · moby/moby · GitHub