Docker Community Forums

Share and learn in the Docker community.

Docker service create with configs

Hi, We are trying to start a docker service with 3 configs. The CLI command is shown below.

docker service create --name ClientPortal --replicas 2 --publish 8080:80 --config src=appsettings.json,target=/app/configs/appsettings.json --config src=connections.json,target=/app/configs/connections.json --config src=config.json,target=/app/ClientApp/dist/config/config.js qabclientportal:latest

It seems like this doesnt work and the 2 replicas are not started. It seems like it tries to start and loops between assigned, preparing, starting and ready etc but it never finishes.

I have tried to use just 1 config and I get the same thing. If I remove the --config options completely then the 2 replicas start fine.

Any ideas whats happening here and how i can debug this?

thanks
Lance

Ok I was able to see that I already had files with those names in those locations that I was specifying with the config command. After changing the image to not have files in those locations this worked.

the error was in the evenlogs.