Docker Community Forums

Share and learn in the Docker community.

Docker Shared Drives hang Windows when asked for credentials

beta
docker

(Johan Westling) #1

Expected behavior

Be able to enter credentials when applying changes in Shared Drives.

Actual behavior

Shared Drives open up the credentials window but Windows become close to unresponsive. No keyboard input is captured by the focused credentials window field & mouse movement lags greatly (approximately 30 second delay on any movement).

Information

Running:

  • Docker v1.12.0-rc4-beta20 (build 5579)
  • Windows 10 Pro v1607 (OS build 14393.5)

Anyone with a different Windows version that has similar issues?

Tried to turn off Windows Defender. Currently running a normal Windows account, no Active Directory on this computer. Any ideas are appreciated :slight_smile:

Steps to reproduce the behavior

  1. Right-click Docker icon in Windows notification area.
  2. Click Settings in context menu.
  3. Go to Shared Drives.
  4. Check the drive you want to share.
  5. Click Apply button.
  6. Credentials window appear but Windows becomes close to unresponsive.

Only way to recover from unresponsive state is by managing to kill the Docker process. This require a bunch of patience (due to the mouse lag).

  1. Hit CTRL + SHIFT + ESC.
  2. Select Docker for Windows in process list.
  3. Click End task.
  4. Windows is fully responsive again.

(Johan Westling) #2

This is solved. Upgrade of docker and editing the wacom tablet settings to use “force proportions” and disabling Windows ink solved the hang.