Docker Community Forums

Share and learn in the Docker community.

Docker Swarm Azure Fail


(Whoisstan) #1

Hi,

this is a post about my docker swarm experience on azure through dockerDOTcom so far.

I assumed that there would be little hicups since it’s labeled (beta), but not the amount of issues I came across.

The first docker swarm I setup on azure via docker.com worked out. I got the instruction to deploy and set the DOCKER_HOST variable on my machine. But when I attempted to deploy I got:

‘Error response from daemon: Get … : getsockopt: connection refused’

Despite following the instructions to the dot. After that any attempt to setup a new swarm on azure has fails like that:


Deployment state: Running
Deployment state: Running
Deployment state: Succeeded
ERROR: Action timed out
ERROR: [2018-01-30T21:45:04.5178865Z] Create swarm-worker-vmss (Microsoft.Compute/virtualMachineScaleSets): Succeeded/OK (in PT2M20.0181075S)
[2018-01-30T21:45:05.7456038Z] Create swarm-manager-vmss (Microsoft.Compute/virtualMachineScaleSets): Succeeded/OK (in PT2M21.2774651S)
[2018-01-30T21:41:26.726026Z] Create externalLoadBalancer (Microsoft.Network/loadBalancers): Succeeded/Created (in PT1.232155S)

Note that this nothing to do with my local setup as I am doing that entirely through the dockerDOTcom web interface. I tried to setup a swarm many times, always the same error sometimes earlier others later.

I wasted a lot of time on service. What can I do to make it work? And, yes, I consulted with docker support but they have been not able to resolve the issue at all and kind of slow. I have been patient, this has been going on for days.

What do I do now?
Stan