Docker Community Forums

Share and learn in the Docker community.

Docker Upgrade Fail


(Evan Montgomery-Recht) #1

Running into a issue, went to upgrade to UCP 0.8. Beyond running into a issue where it 0.8 wasn’t available yet on my account yet, it seems like the UCP lost itself, where only 1 node (out of 2) nodes were registered. (It looks like it tried to upgrade 0.7.1 to 0.7.1). I probably should have tried restarting docker first. Instead did the following, which seemed to bring everything back together.

  1. Upgraded the UCP controller again
  2. Upgraded the UCP node again
  3. 2nd node was missing
  4. Redid a join with a --fresh-install, which was successful
  5. Still no 2nd node
  6. Restarted both nodes
  7. Still no 2nd node
  8. Logged out
  9. Logged in, initially NO NODES, then after about 20 seconds both showed up.

Suggestion, is there a way some type of “notification” showing that the swarm is trying to come back together? Or possibly showing that there is a “missing node”.


(Vivek Saraswat) #2

Hi Evan,

What was the command you inputted for the original upgrade? Most likely what happened is that since you are using upgrade from a 0.7.1 bootstrapper, it defaulted to the 0.7.1 image.

Edit: The upgrade issue looks like an error in the 0.7.1 release where it considered itself to be the latest version. For that release you can explicitly pull the latest image first. Or, another workaround is to note the specific image when upgrading: (e.g. docker run [args] docker/ucp:0.8.0 [more args]


(Ryan Wallner) #3

i can confirm needed to docker pull docker/ucp:latest before running upgrade