Docker wont install logstash using docker.elastic.co/logstash/logstash:5.5.0

So, I’m using command below to run and install logstash with configuration file of logstash. Docker will only install logstash using logstash5.5.0 but If I define docker.elastic.com/logstash/logstash:5.5.0 instead of logstash 5.5.0. It doesn’t recognize the command.

sudo docker run -d --name logstash -p 5000:5000 -p 5044:5044 --link elasticsearch:elasticsearch -e "xpack.security.enabled=false" -it logstash:5.5.0 -e 'input { beats { port => 5044 type => iis } } filter { if [type] == "iis" { if [message] =~ "^#" { drop {} } grok { match => { "message" => "%{TIMESTAMP_ISO8601:log_timestamp} %{WORD:S-SiteName} %{NOTSPACE:S-ComputerName} %{IPORHOST:S-IP} %{WORD:CS-Method} %{URIPATH:CS-URI-Stem} (?:-|\"%{URIPATH:CS-URI-Query}\") %{NUMBER:Port} %{NOTSPACE:CS-Username} %{IPORHOST:C-IP} %{NOTSPACE:CS-Version} %{NOTSPACE:CS-UserAgent} %{NOTSPACE:CS-Cookie} %{NOTSPACE:CS-Referer} %{NOTSPACE:CS-Host} %{NUMBER:SC-Status} %{NUMBER:SC-SubStatus} %{NUMBER:SC-Win32-Status} %{NUMBER:SC-Bytes} %{NUMBER:CS-Bytes} %{NUMBER:Time-Taken}"}}}} output { elasticsearch { hosts => ["local:9200"] manage_template => false index => "%{[@metadata][beat]}-%{+YYYY.MM.dd}" document_type => "%{[@metadata][type]}"}}'